All NFS shares broken since upgrade to 3.8.16

# grep rockstor- /var/log/yum.log |tail -3
Jun 25 00:01:14 Updated: rockstor-3.8-14.x86_64
Nov 16 22:14:35 Updated: rockstor-3.8.15-0.x86_64
Dec 17 23:23:23 Updated: rockstor-3.8.16-1.x86_64

# cat /etc/exports
/export/data *(ro,async,insecure)

# find /export/data/

If I reboot a couple of times it starts working again (a single reboot into the new kernel and rockstor version did not help).


I’m experiencing the same thing now. After I updated to 3.8.16-1 and rebooted, my /export/*/ directories were present but had nothing in them. It seems to take a few reboots before the export directories get set up to point to my shares again.

I’ve tried “systemctl restart nfs” and “systemctl restart nfs-server” to no avail. /var/lib/nfs/etab shows all the appropriate mounts of my exports, but the exports themselves just aren’t linked to the /mnt2/… directories.

This appears to be similar to both Export not pointing to share after boot and Somethings broken the Mounts?

By the way, I’ve rebooted a bunch of times, and did a full power-off / on, and I still can’t get my shares back. I wonder if there’s some sort of race condition in the rockstor service setting up the NFS mounts.

In my case, I was having trouble where in the /export/<share>/ directory were listed various snapshots, but not the actual share data. I kept getting “resource busy” errors trying to delete snapshots, and after many reboots I was able to clear out all of my snapshots since I didn’t need them anyway. I verified that I had no snapshots on any btrfs subvolume via commandline and listing them from /mnt2/<share>/ as well.

However, when the exports fail to mount properly, the share directories are still there, and they still list old but empty snapshot directories in them. When the shares do mount properly, if I run umount /export/<share> then the share directory is still there, and lists old (empty) snapshot directories. I cannot delete those directories directly via commandline (it spits at me with “operation not permitted”).

Anyone have any ideas how to get rid of that stale crud in /export ?

Restarting the rockstor service via commandline hides that and gets the shares mounted again. So my shares are at least showing up via NFS again now. I’ve turned off all of my snapshot tasks for now until I can figure out what that crud is in /export when shares aren’t mounted.