Announcing Rockstor 3.8-11

My fellow earthlings with Storage needs!

3.8-11 is now available and second time in a row, I managed to save my weekend! The community activity has been extra ordinary this cycle. Thanks! We closed 24 issues, 11 more than last time around,

The two major ones this time around are UI template overhaul and significant Rock-On improvements. Plus a bunch of neat fixes and enhancements! Special thanks to @ganti_priya and @phillxnet! Please read the announcement blog post for more details. Also, here’s a discount code for first 25 Stable Update subscriptions: ROCKSTOR3811

I am sorry if we missed any issues you were particularly interested in. 3.8-12 work will promptly begin after the consumption of some fine IPA.


For anyone wishing to check their iso image integrity:-

md5sum Rockstor-3.8-11.iso 
fbb65344b31c7715807750e58e99f788  Rockstor-3.8-11.iso

Now seeding the new torrent.

Thanks for making it available, and all the hard work!

1 Like

Thanks for your work on this!

Always look forward to updates. Thanks for the hard work. I’m looking forward to more monitoring tools to keep on eye on my drives.

EDIT: So I ran the update and it seemed to do its thing. I lost the web gui but could still access the console. I let it sit for a while then did a reboot at the machine. It rebooted and I could access the console and the web interface but it says Im still on 3.8-10 and now Samba wont start. When I do I get errors. Should I try running the update again?

EDIT2: When I tried to run the update again nothing seems to happen. The window pops up and the countdown starts but it never seems to update.

Samba error:
Failed to start samba due to a system error: Error running a command. cmd = ['/usr/bin/systemctl', u'start', 'smb']. rc = 1. stdout = ['']. stderr = ['Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.', '']

Can you run yum update and report what it says? Sounds like a package dependency issue.

I ran yum update and it seemed to update ok. Hard to see all that was going on with how fast it was scrolling. I ran the update and the same issue. It did the countdown, but nothing happened after it. I can turn Samba on in the Samba Services screen, but it has the thinking circle going forever.

EDIT: This error finally popped up after trying to turn Samba on

‘Unknown internal error doing a POST to /api/sm/services/smb/start’

That POST error typically means samba is taking a while to start, but Rockstor is giving up. First off, does your web-ui now show that you are indeed up to date?

Sometimes just waiting and refreshing will show that samba is on. If not, you can manually check with systemctl status -l smb nmb. Depending on the reason why it’s taking a while, restarting samba from the web-ui also fixes the issue sometimes. If the problem is a bit more serious, most of the time it’s due to a failure in rockstor-bootstrap service. There will be clues in systemctl status -l rockstor-bootstrap.

Please let us know how it goes. Looks like the root cause/trigger is the fact that there are just too many package updates, perhaps due to recent CentOS 7.2 release. But there’s something we can also improve on the ui side. your feedback will help us do that, so thanks!

The Web GUI is still showing that Im running build 10. When I ran t [quote=“suman, post:9, topic:953”]
systemctl status -l smb nmb

It came back as “failed to start.” in red. So I ran

and it says its “active” in green. Is there a way I can save the logs of what those display so I don’t have to take a picture with my phone to show you what it all says?

ok, I think a simple restart of samba service from the web-ui should fix it then. You can also manually do that with systemctl restart smb nmb and check the status again.

I hear you re: capturing shell output. We have an issue filed to add support for shell via web-ui, that will ease the pain. In the meantime, ssh terminal(putty program on windows) is the way to go.

When I try to turn Samba on in the Web GUI it says
Failed to start samba due to a system error: Error running a command. cmd = ['/usr/bin/systemctl', u'start', 'smb']. rc = 1. stdout = ['']. stderr = ['Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.', '']

When I run systemctl status -l smb nmb I get this error.

Running systemctl status -l rockstor-bootstrap gives the following

and running systemctl restart smb nmb gives the following.

and on top of all this. When I try and upgrade to build 11. Nothing happens.

Thanks for providing the right output to help debug. It’s clear from smb status that there’s a dependency issue. Before you try anything else, let’s make sure you have all the package updates. Please run yum update and if there are any errors, pastebin the output like you just did. If the command seems to succeed, you can run it again and make sure it reports that there are no updates. Let’s get this confirmation before troubleshooting further.

Here is the patebin for yum update it wont let me scroll all the way to the top to copy/paste the entire output but I took a screenshot as soon as I entered the command.

Thanks @tobb555, these pastebins and screenshots are of great help. Clearly this is a timing issue with massive number of package updates from upstream. If you read the screenshot, there’s a possible solution. Basically, there’s some yum cleanup required. Execute the following commands:

  1. yum install -y yum-complete-transaction
  2. yum-complete-transaction --cleanup-only
  3. yum history redo last

Please do report back the output.

I saw the commands in the beginning, but wanted to make sure that it was ok to run them. Here is the pastebin from those commands Look like the redo last doesnt work. I looked around on google trying to find an answer but I’m not really that great with linux. Sorry.

I understand. This is useful feedback for me too as we are sure to make the update process more transparent and robust(in dealing with upstream changes we don’t have control on).

Glad to see the transaction cleanup did not make a fuss. I made a mistake in the redo command, it’s corrected now. Try yum history redo last. LMK

That worked

Ok, that’s a good sign. Now try yum update. Please continue to report back the output, very useful!

Thi is as much as I could copy/paste