Error - After install first webui login

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Logged into the webUI for the first time. Received this error.

I had Rockstor running previously with no issues. I wanted to change the system disk from my 4TB drive to a 256gb nVME SSD. The install went ok, but when I logged in I received this error. This was a new SSD drive.

Detailed step by step instructions to reproduce the problem

Open WebUI and login.

Web-UI screenshot

rockstor%20snipit2

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py", line 40, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/disk.py", line 272, in post return self._update_disk_state() File "/opt/rockstor/eggs/Django-1.6.11-py2.7.egg/django/db/transaction.py", line 371, in inner return func(*args, **kwargs) File "/opt/rockstor/src/rockstor/storageadmin/views/disk.py", line 218, in _update_disk_state p.uuid = btrfs_uuid(dob.name) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 919, in btrfs_uuid [BTRFS, 'filesystem', 'show', '/dev/disk/by-id/%s' % disk]) File "/opt/rockstor/src/rockstor/system/osi.py", line 104, in run_command raise CommandException(cmd, out, err, rc) CommandException: Error running a command. cmd = ['/sbin/btrfs', 'filesystem', 'show', '/dev/disk/by-id/nvme0n1p4']. rc = 1. stdout = ['']. stderr = ['']

@jsmith100 Welcome to the Rockstor community.

From the following:

I suspect this failure is down to an older udev or associated helpers which from memory were not yet nvme ready. That’s a fault of our ISO installer being so old. More on this soon hopefully.

So what you could try is to update your system via the command line. Logged in as the root user at terminal try the following command:

yum update.

That should update the entire system and we can take it from there. You may need newer a newer Rockstor package but I think we had nvme working on the ISO level of Rockstor. But we can circle back around to that once we have tried a system wide update.

This update is going to take ages as it’s greater than 2.5 years of updates. But once they are all in and the terminal has completed it’s wok. Do a reboot to put the updates into play and then see how it goes.

Basically my suspicion is that udev and friends, back when the ISO was made, didn’t know about nvme properly, ie how to extract its serial number etc. And Rockstor depends on by-id names which are created by udev via a devices serial number. Hence no by-id name for the nvme and so the reported error. If all upstream (CentOS in this case) updates are applied you will hopefully have a better experience. And if now we can take it from there.

With your reply do copy in the output of the following:

yum info rockstor

as that will help with tracking this down further, if required.

also the output of the following would be good:

ls -la /dev/disk/by-id/

Hope that helps.

Thank you very much for the assist! The yum update fixed it perfectly. I had to install the older version because the ISO for the 3.9.1 version kept giving me issues and wouldn’t start the install. I burned a disk for every version from 3.8.15 - 3.9.1 and the only one that worked was 3.8.15. It worked from both CD and USB. The USB or CD approach with the others didn’t work.

Here are the printouts:
yuminforockstar

ls_la

Thank you again for the help! Now to have some fun configuring this bad boy!

@jsmith100 Well done and glad you finally got it installed. And yes we do need a more modern installer. And we have one ‘in the works’ that we are hoping to release pretty soon. Just a few more hoops to jump through and it should be ready.

Since you went so far back to get a successful install it would probably be as well to know the exact Rockstor version you are now on.

yum info rockstor

should have produced this information. You would need to run it as the root user that you created during the install. This will help when asking questions on the forum in the future.

Cheers.

My fault, I didn’t run it as root and I was in a hurry. Here you go! Thanks again for the help!

rockstar_version