Help - Lost Web,Samba NFS access

Hi All,
I’ve completely lost Rockstor!
It started off with just loosing connections to the samba folders,
Now I can’t get into the web folder for management.

How do I bring the system back? I;ve seen that a update may have caused this from 3.10 to 3.11 and I think there was an option to auto update???

Could this have caused this, and how do I bring the system back to get the files off if nothing else???



@psfletcher Welcome to the Rockstor community. Could you give any more details on what you have tried, also the version of Rockstor you were using just prior to failure, ie 3.10 / 3.11 are very old releases now? Can you still ssh into the system or do you have console access. These details will help others in assisting you. There is a know issue where the UI can become un-responsive but this doesn’t affect the samba access. Do you reboot your machine at all?

Hi Philip,
Thanks for posting!!!
Sorry the OS I installed was "Rockstor-3.8-10"
I can’t ssh into the OS, but I don’t think I have ever been able to… (Never tried)
Its installed as a VM, and I can console onto it with the root account and my personal account and look around. I just don’t know where I am looking!
The VM has gone down a couple of time recently when I was working on my ESXi box, but I hope I did this gracefully each time.
It started when I only lost samba with the web interface (on the same port as the samba) and the NFS (on a different port) still working .
But after another reboot, I have lost all three!!!
Also and this may have been when it started (there is also another post on the forum about this) I changed the management/samba interface IP address - I needed to sort out the subnet. Could that have caused any issues???

Any suggestions on how to get it back?? even better if I can get into the SCP/SFTP access and get the files off, I’d be a lot happier trying to recover the OS! Is that possible?

Thanks for replying!


The subnet change would have caused it probably, do you know how to add a second IP to your active NIC in windows or linux? If so, add the old subnet with a random IP, and the old subnet, then see if you can hit the old IP for the interface. Use the IP not the hostname. If you are not sure, then download a tool to scan for IP’s like netscan or nmap for linux, and scan that old subnet to see what IP’s are currently responding. Then see if you can hit the web interface.

No I don’t I tried the ubuntu commands I know and it didn’t work.
Can you point me in the right direction to change the IP?
Also where will the files be stored? can I navigate to them just to prove the files are still there?
Thanks for the replies!


Anyone??? I can still ping the interface what ever IP address it is.
But there are no services linked to it.
What do I need to do to relink ssh, smb and sftp back to a interface???
I don’t know the command line well enough to work out what to do!

I can get in on the VM console, so I can still see things, where are the files kept?
It would be good just to ensure there still there!!!

Please help I’d like my files back!


You can see the mounted devices with “df”.
there might be something like "/mnt2/YOURPOOL/YOURDATASHARE"
With ls /mnt2/YOURPOOL/YOURDATASHARE you see the filestructure.

Unfortunately I’m also not a Linux professional and not really familar with how to get your system back running. I’m sure it won’t be too hard…

BUT you can reinstall Rockstor WITHOUT loosing data. Thanks to btrfs Filesystem. I did it myself twice and had no problems.
The OS-Reinstallation process doesn’t affect the data (if you don’t install the OS on the same HDD as you have your datashare on.

1 Like