Missing custom rockon, not showing up with update [Solved]


I have a custom rockon for plex, which i have added hardware accelerated en/decoding.

But yesterday as i was trying to add a folder, it has disappeared completely. The rockstor logs don’t mention anything and the gui doesn’t show any errors when i try to update.

Any advice on how i can find it again?


Ok, so i tried to rename the rock-on file and gave the container a new name and then i get this error. (see below)

So why isn’t it showing up in the list of rock-ons.

    Traceback (most recent call last):
  File "/opt/rockstor/src/rockstor/storageadmin/views/rockon.py", line 107, in post
self._create_update_meta(r, rockons[r])
  File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/utils/decorators.py", line 145, in inner
return func(*args, **kwargs)
  File "/opt/rockstor/src/rockstor/storageadmin/views/rockon.py", line 186, in _create_update_meta
handle_exception(Exception(e_msg), self.request)
  File "/opt/rockstor/src/rockstor/storageadmin/util.py", line 47, in handle_exception
RockStorAPIException: ['Duplicate container (plexhw-linuxserver.io) definition detected. It belongs to another Rock-on (Plex-hw). Uninstall one of them and try again.', 'Traceback (most recent call last):\n  File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/sync.py", line 68, in run_for_one\n    self.accept(listener)\n  File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/sync.py", line 27, in accept\n    client, addr = listener.accept()\n  File "/usr/lib64/python2.7/socket.py", line 202, in accept\n    sock, addr = self._sock.accept()\nerror: [Errno 11] Resource temporarily unavailable\n']

Hi @Rene_Castberg,

The error you are seeing indicates Rockstor can still see the same container name in its database. When you tried to rename the container, did you rename the actual container line in the JSON file or just the json file itself? In the example below, for instance, it would be the "ghost" name (line 5):

Coming back to your first post, however, could you describe the steps (as you remember) that lead to the Rockon disappear?

I renamed both, the file and the container, but it still uses the same image. (Even though original file is gone)

How it happened.
I tried added an extra share to the container, and the pressed uninstall on what i thought was the container below. Plex disappeared, and the other container remained. I uninstalled the other, thinking i could just add plex again. But it was gone in the list of images and also gone from the active images.
Could there be some remnants hanging around in the db?

I have no idea what went wrong, but i managed to “fix” the issue by using the delete-rockstor script.


After it deleting all the database entries it showed up in the list of installable rock-ons and in the list of installed once i installed it.

1 Like