New install, all set up windows can't find it

Hi, all installed ok, Web interface up and running.

only problem is windows will not find the drive at all.

I’ve done the basic Google searches but nothing has worked. I’ve installed plex app and windows can see that.

Can anyone help.

It’s a simple system.

Old pc case with a lag 775 athlon 2.8ghz dual core 64 but. 4gig of ram in 2 sticks. A ssd 32gb boot drive and 2 western reds 2tb in raid 1.

thanks in advance


So, you have a system running rockstor, you can access the web-interface, but you cannot use the drives in Windows?

Just a few basic steps to take:

  • Make sure you actually “created” a disc. Since you mention you have the drives in Raid1, I take it you used the web-interface to complete this step.
  • You should create shares on the disk-pool. See the documentation on this. Make sure the user you plan to use in Windows to sign on with has access to the Share!
  • Enable a protocol for the Share. Windows prefers Samba, so make sure you have that service running in Rockstor.
  • If you have Samba enabled, you need to specify which Share you want to publish over it.
  • If you have your Samba service configured, aka you published a Share and you know which users have access to it, you can go to explorer and Add a Networkdrive: the address of a SMB target = \IP\sharename. (example: \\Photo)
  • Windows will ask you to input a username & password, after which you should see the drive listed in Explorer.

If you get stuck somewhere, have another look here;

Or just tell us here which steps you got past and what kind of errors / unexpected things you run into.


Thanks so much for this. Will work though and let you know

Still no joy , i have created the samba share as discussed. Everything i do in windows comes back with the same message.

It doesnt matter if i just try the ip address alone or the share.


after a week of messing around and reading 100’s of Google searches nothing has worked. :confounded:

A friend said , have your tried a different operating system, so an hour later a new install on an old laptop that was running windows 7 (no it couldn’t see the drive either). A nice new vision of Ubuntu installed and as soon as you hit network drives, its there, no issues at all. No need to input IP address or passwords.

Any adjustments made on the gui are there on re fresh.

But why will windows not see it at all?

Only thing I can do is to try and get photoshop to work on Ubuntu but I don’t think its straight forward.

Thanks again