Openvpn failed to install

I am having trouble installing the openvpn rock-on. When I first tried to install the rock-on, I got the message:

Failed to install in the previous attempt. Here’s how you can proceed.
Check logs in /opt/rockstor/var/log for clues.
Install again.
If the problem persists, post on the Forum or email

I looked at the logs, but I didn’t understand what I was looking for. I also tried to install again with the same outcome (not surprising as I didn’t change anything). Can someone help me look into this?

Another question – Can I just install openvpn via yum and set it up manually or would that cause problems?

Welcome to the Rockstor community @sudowoodo!

Have you tried this with 3.8-4? the latest update rolled out a couple of hours ago? Also, just to make sure you have the latest rock-on meta data, click the update button on the rock-ons page before attempting the install.

Thanks suman! Actually I did try this after updating to 3.8-4, but I didn’t click the update button before I tried to install again. I just tried and the install still failed. Any other suggestions?

Some new information: There system seems to be endlessly creating new snapshots on the rock-ons-root. It stops after a reboot.

EDIT: Sorry I was wrong. This occurred on 3.8-3, but I just checked and it is not still creating new snapshots.

I just reproduced it. I know this bug, the fix hasn’t made it to 3.8-4 unfortunately. It’s an easy fix. Could you try the following?

  1. backup /opt/rockstor/src/rockstor/storageadmin/views/ (copy to .bkp or something)
  2. download this file and replace the above with it.
  3. systemctl restart rockstor

Then try installing the OpenVPN rock-on again. If it’s still doesn’t get installed, can you zip /opt/rockstor/var/log directory and email it to please?

1 Like

If it’s a hassle to download and replace, You can make a backup and then edit it. It’s a simple edit. Change line 32 and 33 to this:

DCMD = [DOCKER, ‘run’, ‘–log-driver=syslog’, ]
DCMD2 = list(DCMD) + [’-d’, ‘–restart=on-failure:5’]

Awesome! That worked. I now see that it has installed. Thanks!

I can also confirm that provided fix is working with the latest Rockstor release.

Thanks guys, the fix got merged and will be rolled out with 3.8-5