SMB only available by IP from Windows Hosts

Good Day Everyone.

I am running into a problem that predates me at this location and I was hoping that it would resolve itself after a rebuild. I will try to explain it and hope we can work this out together.

I have NAS box that had 3.9.1-16 on it and completely wiped clean. New system has been rebuild with orinigal 3.9.1-0 and then upgraded immediately to 3.9.2-48.

I have configured NFS and SAMBA shares on this machine.

What I am running into is that from a Windows machine if I try to access the SAMBA share I am not able to connect by the actually hostname of the machine (co-nas01). I am able to use the IP address.

I have put the netbios name = co-nas01 with no luck.

From the windows machine I am able to resolve correctly with nslookup and ping. Everything but windows explorer is able to connect to the machine by hostname. Here is the trick. If I create another name in DNS as co-nas02 to the same IP address. This works without issue. I prefer not to have the second name and just use co-nas01 everywher.

Has anyone else seen this issue and maybe resolved it themselves.

P.S. In a web browser I am able to connect to co-nas01 without issue to manage environment. I just can not connect to SAMBA with the hostname that I want. I have another Rockstor that has never had this issue.

Regards,

Ken Parr

testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section “[homes]”
Processing section “[printers]”
Processing section “[print$]”
Processing section “[AcroBackup]”
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

Global parameters

[global]
map to guest = Bad User
printcap name = cups
security = USER
workgroup = SAMBA1
idmap config * : backend = tdb
cups options = raw

[homes]
browseable = No
comment = Home Directories
inherit acls = Yes
read only = No
valid users = %S %D%w%S

[printers]
browseable = No
comment = All Printers
create mask = 0600
path = /var/tmp
printable = Yes

[print$]
comment = Printer Drivers
create mask = 0664
directory mask = 0775
force group = @printadmin
path = /var/lib/samba/drivers
write list = @printadmin root

[AcroBackup]
comment = Samba-Export
guest ok = Yes
path = /mnt2/AcroBackup
read only = No
root preexec = “/opt/rockstor/bin/mnt-share AcroBackup”
root preexec close = Yes
[root@co-nas01 samba]#

Well I was able to find the solution. With the help of a co-worker. It turns out hat there was a computer entry in AD for this Linux box. Once this entry was removed and replication occurred. The computer name was recognized properly.

One area that I did not look myself and I tried what I felt everything.

I hope this help some one the future as no other searches I did came close to pointing me in this direction.

2 Likes