[Solved] Can't re-create SFTP shares after migrating to 4.1

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Following migration from 3.9 to 4.1 I’m trying to recreate some SFTP shares that existed on the previous setup.

Detailed step by step instructions to reproduce the problem

SFTP Service enabled
Storage - File sharing - SFTP - Add SFTP Share
Select folder to be shared.

Web-UI screenshot

[Drag and drop the image here]
SFTP%20Share%20error

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/sync.py", line 68, in run_for_one self.accept(listener) File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/sync.py", line 27, in accept client, addr = listener.accept() File "/usr/lib64/python2.7/socket.py", line 206, in accept sock, addr = self._sock.accept() error: [Errno 11] Resource temporarily unavailable

But the folder(s) I’m trying to share are NOT owned by root:

Folder%20ownership

As I said these worked perfectly in 3.9. I don’t know if the fact I also lost my Samba shares (since recreated with no issues) in the migration is relevant.

Something else I’ve noticed which may, or may not, be relevant.

Although the SFTP service was enabled by restoring my 3.9 config the ‘mnt3’ directory doesn’t exist any more.

I don’t know if this is created when the service is run or when the first share is created - which I can’t do - so this may be nothing.

the mnt3 directory is created the first time a “successful” sftp share is initiated. I have not been using them, but after creating a non-root share (using the built-in sftpuser as owner and some other group), it creates the mnt3 directory automatically (and also no error message).

I assume the owner/group ownership of the Emby_* shares also shows up that way in the WebUI (don’t know why it shouldn’t)?

The user EmbyBackup is not part of the root group as well?

Can you try another test sftp share where you explicitly select some other owners for the underlying share (that are obviously not EmbyBackup or root)?

2 Likes

@Hooverdan You nailed it!

For some reason the shares all showed up as root / root in the Web UI.

I knew they weren’t owned by root (and I proved it by checking on the CLI) so I never actually thought of checking whether the Web UI showed anything different. As you said, why would it?

So I changed them in the Web UI and now I have my SFTP shares back. So simple.

Thanks.

2 Likes