[Solved] Installation fails on HP Microserver N40L

I downloaded 3.8-7 today and got the same error than on 3.8-0 iso. I am not able to get to the installation at all, it stops at boot time and brings me to some shell.

I managed to download the rdsosreport.txt file if this gonna help.
I managed to run Debian/Ubuntu on the system before without any issues. It is a standard N40L with a remote access card an 8GB ram.
The installation was done using an USB stick and the only attached drive at the moment is the SSD which should be used for the system itself.

Thanks for helping
Because I am not allowed to upload the file, I have hosted it on copy.com (https://copy.com/xxSEd1jVrFx6BTwp)

@suman @phillxnet, i dont know the exact thread, but this seemed to be an issue somewhere else where adding the kickstart file on the bootloader level fixed things.

the important line would be
[ 22.016886] localhost dracut-initqueue[585]: Warning: failed to fetch kickstart from hd:LABEL=Rockstor\x203\x20x86_64:/ks.cfg

edit: here it is

I resolved the issue myself.
I didn’t know that is a must to use dd or rawrite to create the usb installation media.

I always used unetbootin for my “whatever” linux/unix installations and it just worked, I haven’t thought about it could be the issue. Reading the quickstart guide again I saw that dd is specifically mentioned. I gave it a try and it is working.
Perhaps someone can mention that specifically that no other tool to create the usb installation media is going to work properly.


@herbert Well done, that’s a nice find. Your problem was puzzling me, I just hadn’t come up with any suggestions. I have heard that unetbootin has more recently been failing to write working boot keys for a number of linux distro’s so it’s good to have confirmation that it’s failing on Rockstor iso’s also. I know it use to be one of the “go to” iso to usb writer program but have never used it myself so don’t really know. We are planning on also adding ddrescue as a suggested usb key writer which has worked for me on the Rockstor iso’s. I heard of using ddrescue instead of dd from Martin Wimpress (co founder of Ubuntu Mate) on a podcast. They detail their suggested use of ddrescue on their download page at:-
https://ubuntu-mate.org/ .

Also good idea on adding to the docs so others might avoid your frustrations and benefit from your findings.
So that this isn’t forgotten I’ve created an issue in the rockstor-docs repository so it might be considered.
Cheers for persevering and sharing your findings.

@felixbrucker nicely remembered. The issue created from that thread has now been sorted / closed by @suman in the 3.8-7.iso and only affected the “… basic graphics mode install” and @herbert said he had tried this iso version so I was still at a loss. Thanks for considering / linking as it definitely looked related and was all I had to go on until @herbert went and sorted it from under us. :smile: Cheers.

regarding iso writers i mostly use lili or plain cd/dvd, will test if this works with rockstor soon and report back. i too had many errors with unetbootin, especially because unetbootin writes its own bootloader, even if the disk has its own, and tries to smartly manage the needed parameters which works for most common OS.

thanks for the feedback and I start loving the community and the way people address topics and replies here. go on with the good work :smile:

never heard about lili but I gonna give it a try as well. thanks for the hint.

@herbert Sorry it took so long but the Quick Start section of the docs has now been updated with your findings re Unetbootin and the issue opened with your suggestion has now been closed.

Thanks for reporting.

no worries :smile:
My system is stable at the moment and I do not intend to reinstall it anytime soon :smile:
I am awaiting the new features hopefully coming soon to rockstor :wink:

this apparently also applies to livecd-iso-to-disk