Unable to logon using URL

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

I am trying to install and configure syncthing. I have uninstalled the rockon as I wanted to make some changes to the base configuration. When I’ve rebooted Rockstor and tried to logon I get an error - shown below

Detailed step by step instructions to reproduce the problem

I had previously uninstalled and reinstalled the syncthing rockon with no problem. One difference this time is that I had added storage to the syncthing config - not sure of that is relevant or not. I normally reboot the machine after uninstalling but when I tried to log back on I got an error!

Web-UI screenshot

Rockstor%20Error

Error Traceback provided on the Web-UI

I am unable to access the GUI

After a second reboot - the GUI is back and accessible again. Please ignore this call

@martino Welcome to the Rockstor community.

Glad your up and running again however that message is a worry. Did you happen to use the “root” share for your extra storage. On earlier versions of Rockstor we still surfaced a “root” share in our Web-UI. This turned out to be pretty buggy and was not what was intended. More recent versions of Rockstor now no longer expose this ‘share’ as if it is used by some rock-ons they can end up break the install by changing write access where they shouldn’t. So best avoid using that now legacy share and create dedicated ones for each purpose.

Hope that helps.

Hi Phill - many thanks for your reply which is much appreciated. When I added a share as additional storage to syncthing, I used a share that I had created myself, though I had used root as the owner of that share.
I have already found a problem with using that share (which is what I was trying to solve). It came up with the error

Failed to create folder root directory mkdir /run/s6/services/syncthing/data: permission denied

This was displayed in the syncthing WebUI.

Should I be avoiding using root as the owner of shares that I create?

@martino Re:

OK, so it wasn’t the “root” share problem I thought it might be then. That’s good.

It’s best if you can; if the Rock-on concerned has a UID/GID setting, to use either of those as the owner/group of the share. We have a disconnect currently in the Web-UI where Rock-ons ask for UID/GID but elsewhere we have user/group names. We will have to address that in time. Again it’s down to the access the Rock-on require of the share. Generally UID input as setting to the Rock-on as owner of the dedicated share should give the Rock-on, by default, full access. As by default the owner of a share has full read and write access. With GID Group ID, it can be a little more tricky depending on the Rock-ons requirements.

Hope that helps

OK, I’ll make these changes and see where I get to. Thanks again for your timely and helpful advice - much appreciated :slightly_smiling_face:

1 Like