Unknown internal error doing a POST to /api/samba

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Samba share is not created. Error displayed: Unknown internal error doing a POST to /api/samba

Detailed step by step instructions to reproduce the problem

[write here]

Web-UI screenshot

[Drag and drop the image herRockstor_Fehler_Samba e]

Error Traceback provided on the Web-UI

none

@Vern, welcome to the forums. Could you provide a little more detail on what you were doing?

Looks like you’re running on the latest release of Rockstor according to your screenshot, so issues that were connected to creating Samba Shares in the past have been programmatically resolved.

Could you clear your browser cache and try again (or run it in a private/incognito window). I’ve seen at least one post where due to some caching behavior, this broke in the UI (though it was related more to Chrome and not Firefox which you seem to be running).

1 Like

Hi @Vern, and welcome!

@Hooverdan already detailed the information needed, but I also noticed an oddity in your screenshot. Indeed, you should see the linux kernel version in the top right header next to the “Uses Rockstor…” text. As you do not, I would be curious to know whether this was a fresh install that was upgraded straigth from ISO, or an older install with progressive updates with time. Similarly, was the machine rebooted since, and which kernel version was selected?

Hope this helps,

1 Like

Hi @Flox,
unfortunately I could not get any more information, it has been years since my last explorations of a linux system. Therefor I re-installed rockstor a few times and at last without updating during the installation I executed yum -y install in a ssh-shell. Afterwards the actual kernel was installed and I could activate smb and set up the shares.
Thank you very much for your instant reaction!
Kind regards!

1 Like