WebUI IP won't work

I’ve reinstalled Rockstor about 8 times, and everytime the webui ip doesnt work.

Hi @ryanaku5,

Can you please advise what WebUI IP is shown on boot?
Typically you should see two,, which is localhost and can only be accessed by the rockstor system itself, and one either configured by DHCP, or specified during the installation process - commonly 192.168.x.x or 10.x.x.x.

If you only see the first, it typically means that either no network connectivity was present during installation (this is required!), or nothing is providing DHCP on your network and you failed to provide an IP address.

Also note that the WebUI is only accessible via HTTPS (https://ip.addr/), and when accessed via IP will always return an SSL error, as the IP address does not match the hostname in the SSL (and the default SSL is self-signed)
Most browsers provide a method to override this.
In chrome, you would click the small ‘Advanced’ link at the bottom, then "Proceed to [IP.ADDRESS] (unsafe)"
In firefox, you would click the grey ‘Advanced’ button, followed by ‘Add Exception’

Assuming the above hasn’t helped, and that you have a valid IP to connect to, could you please advise what your browser says when you attempt to navigate to this IP?
Please also provide results of a ping test from the host you’re using to access the Rockstor WebUI.
If you’re not sure how to run a ping test, google should be able to provide easy to follow instructions.

Hope this helps!


i do have the same problem … what service run the web-ui ?

Hey, sorry to revive a dead thread but i’ve had a similar issue. Whenever I try to connect to the webui ip (192.168.x.x) the page says the connection was refused, even if i whitelist them. I also ran a ping test and got this back:
Ping statistics for 192.168.x.x:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 8ms, Average = 4ms

I’m not sure what i’m missing.

@D1e5le Welcome to the Rockstor community.

Are you sure you using https:// in front of the ip and not just http://, you didn’t specify either.

You ping suggests you have the correct ip hence my suggesting the protocol.


Hope that helps.

Yes I have been using https, but it still says refused connection


Is this a fresh install and you have yet to connect successfully or has this worked in the past and has now stopped working. Also give some information about the system, what you have installed Rockstor on etc. I.e. are you using a fast USB key, a HDD, SSD. Often a little info can go a long way but the more the better mostly.

So more info and a history that lead to this situation. That way forum folks have got more to work with to help you.


Right, sorry. It is a fresh install on a 250gb hhd w/ 2gb of memory (more otw)
also I’m unsure the network was set up correctly because i don’t think it had a proper network connection when I installed it, but the ip address shows up so i think it works.

@D1e5le For simplicity I’d just do a re-install now that you have the network.

And when you go through the installer just go with the defaults, i.e. don’t configure the network in the installer, we do this ourselves on first boot. It defaults to DHCP which is most likely what you want. You can always change it via the Rocsktor Web-UI.

Give that a go. And make sure you have DHCP enabled on your router (this is normally the case) and do the install over. As you say it looks to be OK but somethings not right and it shouldn’t take too long to re-install. Now you have the network sorted.

Worth a try.

Under the network and host name tab of the installation screen it says no network devices available.