Announcing Rockstor 3.8-11

ok, one step forward, two steps backwards now :frowning:

Two more commands for you to try:

  1. package-cleanup --cleandupes --skip-broken
  2. yum update

Looks like it deleted 195 items and updated/cleaned/verified 154 items. Looks like I cant access the Web GUI anymore but I can still via SSH.

ok, output would be helpful. What’s the output if you run yum update one more time?

when I ran package-cleanup --cleandupes --skip-broken It deleted 195 items but I didnt save the logs from it but here are the logs for yum update the first time I ran it and the second time I ran it.

EDIT: I rean yum info rockstor and it out came back with this. So In theory I should be on build 11 right?

Great. It’s looking promising. I think every package is now updated and yum is happy. it’s just a matter of starting/restarting rockstor services. You can do that with

  1. systemctl restart rockstor-pre and wait until it shows “active” in systemctl status -l rockstor-pre
  2. systemctl restart rockstor and wait till active like above
  3. systemctl restart rockstor-bootstrap and wait like above…

Please do report back the output of status commands for sanity check. If all goes well, web-ui should be back online.

I got the follow error when I tried to run systemctl restart rockstor-pre

Job for rockstor-pre.service failed because the control process exited with error code. See "systemctl status rockstor-pre.service" and "journalctl -xe" for details.

ok, we are not completely out of the woods yet. Please share the output of systemctl status -l rockstor-pre and journalctl -xe commands.

systemctl status -l rockstor-pre and journalctl -xe is 1241 lines long. Pastebin was unhappy with it being that long. Is there anything specific you’re looking for or an easy way to save it as a .txt and just retrieve it?

the key line was included in the output

Jan 28 14:20:49 nas systemd[8786]: Failed at step EXEC spawning /opt/rockstor/bin/initrock: No such file or directory

This is pretty bizarre. /opt/rockstor is where all the files of the rockstor package live. Did yum completely nuke that directory?

This doesn’t make sense because yum info shows that 3.8-11 is installed. After verifying the contents of /opt/rockstor, you could try yum update rockstor and see if that pulls the files again?

I looked in /opt/rockstor and the only folders were certs src static var and the update reports back

`[root@nas rockstor]# yum update rockstor
Loaded plugins: changelog, fastestmirror
Rockstor-Stable | 2.9 kB 00:00
rockstor | 2.9 kB 00:00
Loading mirror speeds from cached hostfile

bummer. that does not look good. Rockstor got uninstalled some how. You can try yum install rockstor and that should install 3.8-11. But I am afraid the application db may not be reusable. But give it a shot and see what happens with rockstor-pre after that. If rockstor-pre start/restarts fine, it’s good(unlikely, though). If not, you’ll have to re-install :frowning: LMK.

Looks like you might be right. I did yum install rockstor and it seemed to work, but after I rebooted the machine I got tons of could not boot errors. If I go and reinstall am I going to need a new key? Despite the issues I had I can’t thank you enough for trying to get me sorted out. I really appreciate it. Support like this is why I don’t mind paying the extra dollars for it.

It’s a disappointing end to our troubleshooting exercise but I am pleased with your attitude and really appreciate all the feedback. Here are the top takeaways I am going to incorporate into future development

  1. software update process must be transparent to the user via the web-ui
  2. web-ui should deal with upstream updates and rockstor updates separately so upstream updates don’t accumulate over time causing problems like these. Again, at least higher transparency will serve everyone better.
  3. make it easy to do shell level troubleshooting and reporting from the UI itself making the shell client-platform independent.

After re-install, you will need a new key. Just e-mail your appliance ID to support@rockstor.com and we’ll send you one.

No worries. I wish I could have helped more. At least we both learning something in the process so its not all in vain. I understand that it’s still in a development state and issues come with it.

Good day @suman.

Just got this on my fresh install (well fresh from couple weeks) as an alert. Following the instructions got the “problem solved”.

Have the team made any progress on solving this without operator intervention? I’m afraid some users my break things going to the shell :slight_smile:

Best regards,
Al