Built on openSUSE testing channel live (early-adopters/developers only)

@lexxa,

Following-up on which rock-on you have currently running… would you have the Netdata rock-on running, by any chance? If yes, I might have an idea.

1 Like

@lexxa,

Sorry for the message spam, but I was convinced it was indeed Netdata and dug up a little more.
It turns out it actually is Netdata generating this error, and it is simply a sign we need to update our rock-on accordingly.

Briefly, there is now an official docker image for Netdata so we need to switch to that one and update our rock-on config accordingly. In particular, we need to add a dedicated apparmor setting to our docker run command for this rock-on: --security-opt apparmor=unconfined.

This should fix it.

@lexxa, as you noticed this error, would you fancy creating a corresponding issue on Github linking to your message here? You would have credit, this way.

1 Like

@phillxnet Hello, the task flow resulting the described behavior was ISO build (quite easy actually, and this comes from a Windows Engineer!), install, zypper refresh, zypper up --no-recommends, reboot, pool import, definition of rockon storage and install of Netdata and Duplicati rockons

@Flox yes indeed, as mentioned above one of the two rockons installed is netdata (went into the shell and enforced execution of the bash version of the lm-sensors, other than that unaltered docker image)

As per github issue, will try to create one in as much detail as possible.

2 Likes

Thanks a lot for creating this issue, @lexxa! I’m linking to it below for reference:

Also, note I submitted a corresponding pull request last night:

I won’t be able to merge it immediately as there are a few backend things that need to be worked out (unrelated to this PR specifically), but we should be able to have that merged and published once it’s compete.

Thanks again for your report, this is an important update that needed to be done so I’m grateful you noticed it and brought it up!

1 Like

I am coming with yet another issue.
On the latest build of rockstor with fully update SUSE.
I am running the duplicati rockon.
Once a scheduled backup starts RAM usage remains basically the same but all available ram gets “cached”. After the job finishes the RAM is still cached and sooner or later the OS gets to write to /swap. After a second run of the backup job /swap gets filled considerably.
Once the backup job finishes the only way to “un-cache” the system is a reboot.

I am ok with using swap but would like another processes (nfs/cifs) to use the availabale ram. I am not sure how to drop the cached pages (sync; echo 3 > /proc/sys/vm/drop_caches) gets the job done but I would hate to introduce inconsistency to the memory content doing this too often.

Any advice how to further troubleshoot or report the issue would be greatly appreciated

Hello again, @lexxa

That unfortunately seems like an issue with Duplicati rather than Rockstor. I quickly lookep it up and it seems to have been a “somewhat common” issue with Duplicati. For instance, I found an issue on their Github page with similar behavior suspecting a memroy leak that seems to have been fixed by a Duplicati update:

I would refer you to the Duplicati project for help about that, unfortunately, as they would be the best positioned to help. The only thing I would suggest is to make sure you are running the latest docker image.

I’m sorry I couldn’t be of more help here.

2 Likes

Bit of an update for whoever might be interested really.

Over the past couple of months I’ve had x86_64 Rocksor 4 running on my home NAS without any issue. Well apart from a motherboard failure, but I can’t point the finger at Rockstor for that one. It is Rock steady (pun intended), reliable and with good performance. No complaints from me or the users (ie my family) for document storage and supplying audio/video media to my LMS/Jellyfin/Icecast server.

I’ve also continued with a fair bit of successful testing on a Pi4 and some further RAID testing in x86 VMs, seeing how Rockstor handles changes to RAID levels, drive loss etc. I believe the newer kernel and BTRFS on Leap is more stable when performing constant tests like this, and more so than the same testing done on the CentOS base which I’ve done in tandem.

I’m not an AD user, so the existing issues with that (which I believe are close to being resolved anyway) don’t stop me from happily using Rockstor 4.

I think my testing has come to a close now, and as I type I’m running one last set of tests changing RAID level from 10 to 1 and other odds and sods in my VMs. As far as I’m concerned it’s fit and forget for me :slight_smile:

One last thing - I’m not a Rockon user (yet), so cannot comment on that area.

Looking forward to showtime :slight_smile:

Geoff

4 Likes

Hello,
New user (old linux hand) - successfully built system with a few 3TB drives I had lying around on an old intel i3-540.
Everything looks good - defined an NFS share and a Samba Share
I keep getting a pop-up error window which totally prevents doing anything in the GUI.
image
Would like to know how to fix this…
Going to datatables.net - recommends fixing code…

@dvgeek Thanks for the report and glad you got the new DIY installer built and deployed.

Yes this has popped up from time to time in a variety of places. The exact cause is likely a bit of us ‘doing it wrong’ somewhere but we’ve yet to narrow it down or get a reliable reproducer in order to know if we’ve fixed it.

The work around, once it occurs, is to simply use the refresh button in your browser. There after it appears to go away. Not specific to the new build but just some lingering issue we’ve had for a while. Again it’s awaiting a reliable reproducer before we can create an issue where we can test/prove whatever fix is submitted.

Hope that helps.

1 Like

Thanks for the quick response @phillxnet
I tried that - clicking on okay / refreshing the browser / etc. but it keeps popping up as soon as I click okay - sometimes I think there could be multiple pop-ups, one behind the other, because it would take multiple clicks on okay for the box to go away - but it again reappears before I click anything else - so preventing any operation in the GUI.

Removed all Samba Shares and disabled Samba.
Using only NFS shares - and it has disappeared - not popping up now ( well for at least the last 30 minutes)…

Raid 6 (I know officially not supported, but…) - 17 x 3TB disks
3 NFS shares
Tried to give an advanced export option of no_root_squash, and got an “Invalid exports input…”
Had to manually edit the /etc/exports file to add this option.
Also the search feature for the forums does not seem to work (or I am not able to figure it out) - in either Chrome or Firefox browsers…

1 Like

Hi @dvgeek, I’ll try to help you with these ones…

I suppose you are referring to using the “Advanced Edits” option/button. Your post actually made me realize we do not cover this function in our documentation so thanks a lot for your feedback. I have now created an issue in our Github docs repository to remedy this:

Now, to get back to your issue, I believe the error you are seeing results from the following part of the code:

As you can see there, this error results from the presence of less than 2 parts in the statement that was used in the Advanced Edit box. As a result, would you be able to detail what you put in this box? Did you input the full export statement or just the no_root_squash option? I suspect the latter given the error you encountered, but let us know so that we can make sure we’re not facing a bug that needs fixing here.

Yes, the search button is unfortunately “hidden” by some sub-optimal css theming. I’ve found a fix for this and need to find the time to implement it; it’s always very risky to alter anything in our forum given its size and how precious its contents are, so I don’t want to rush anything. Bottom line, you will find the search button in the top right corner, to the left of your avatar, it will reveal itself when your cursor hovers over it… see a screenshot below:
image

Hope this helps, and thanks again for your feedback… let us know how it goes.

2 Likes

Thank you for your response. Yes, you are quite correct - I put in just no_root_squash without quotes and with quotes. I also tried with and without brackets. So, if I understand this, as the code is expecting two parts in the statement - does that mean that I would have to enter entire line as in /etc/exports - for ex:
/export/MyWkStnBackUp *(rw,async,insecure,no_root_squash) ?

If this is the case, something that would have made this intuitive would be to repeat the automatic entries in the manual export entries box. Then the user would know where to enter the advanced options. Just a suggestion.

Also, in my younger days (now retired), having supported multiple devops in the systems & storage areas - I feel happy if something I noticed & commented on helped contribute to a better functionality/product.

1 Like

Yes, that is my understanding (I actually haven’t had time to try that myself, but that’s what I could gather from searching through the forum posts).

Agreed that it’s not really intuitive at the moment, and good idea. As it, the “Advanced Edit” button is more of a “Create a manual export” so we might want to improve that wording while we’re at it. Would you mind creating a Github issue with your finding and idea? Here’s the link to the repo issue tracker: https://github.com/rockstor/rockstor-core/issues This way we can keep track of it and correctly credit it to you :wink:

1 Like

I will test it at the first opportunity - could still be after 24 hours as system will be busy backing up media.

I’m not looking for any credit - thank you - just trying to help, if I can. This is not a major issue and can be fixed with documentation. Do not want to burden dev’s with another issue when they are busy readying the product for stable release. I will create it as a feature request - so that the dev’s who look at this can prioritize accordingly. Thanks again.

As requested - new issue is open

3 Likes

Couple of new observations / issues

  1. Cannot download logs - tried both ways (Download Logs Archive & Through the Logs Reader) - Error message is “Couldn’t download - No file”
  2. The Rockstor log is full and is filled with this message "
[14/Jan/2021 09:20:52] ERROR [system.osi:196] non-zero code(1) returned by command: ['/usr/sbin/btrfs', 'qgroup', 'show', '/mnt2/Data/PlexBackUp']. output: [''] error: ["ERROR: can't list qgroups: quotas not enabled", '']

Not sure if something needs to be set-up. If these are issues - I can move this to the issue tracker - but just wanted to check before doing that.
Thanks

Hi again, @dvgeek, and thanks a lot for the feedback :wink:

I tried to replicate it on Rockstor-4.0.5 and both ways worked for me… I’m unfortunately not familiar with this area of Rocsktor so I’ll have to dig a bit to have some idea of what could be happening. Do you see the link created when clicking on “Download Logs Archive”? If so, does it look like https://<rockstor-ip>/logs/requested_logs.tgz?

That is the normal and expected behavior when quotas are disabled. We actually had a discussion about improving this as it can be misleading, indeed. The forum thread is below:

… with the corresponding Github issue for reference:

Sorry I can’t be of more help with the logs issue at the moment…

Yup - I can see the link - and the browser tries to download the file - but errors out with the message “Couldn’t download - No file”. I could copy and paste the download link - and then I get a 404 Not found.
Tried with a couple of different browsers too - didn’t work.

Too bad about the logs - any way it can turned off or change level of detail ?