Cannot Install or Boot

Alright, so I have my old HP P2(1322) and I had read about turning old computers into home media servers. I read that Rockstor was one of the best free os’s to use and that it was fairly straight-forward.

So I downloaded the .iso, used Rufus to format a bootable USB thumbstick and plugged it in. After configuring the bios to boot to the usb, the menu popped up and asked me what I wanted to do. I selected “Install CentOS 7.” It seemed fairly promising.

It started giving me error messages, the same one over and over, saying “Dracut-initqueue[557]: Warning: Dracut-initqueue timeout - starting timeout scripts.”

Then, it says “Warning: Could not boot, Warning: /dev/root does not exist. Starting Dracut Emergency shell…”

What should I do?

Thanks, Emmett

Hi @RiverChicken886,

I had the a similar issue, and mine was resolved by downloading an earlier ISO (Rockstor-3.8.16), then updating post-install.

Hope this helps!

Sorry @Haioken, I still got the same result with the older ISO. I didn’t need to do anything to the hard drive like format it or anything did I? I had ubuntu on this hard drive before, but I also tried switching it out with a formatted one, but to no avail. Any other ideas?

This is where it gets difficult.
The error you’re receiving is a failure to boot the installer, so unfortunately not something so simple as formatting the disk.

I had this when using a particular model of USB stick as well (sorry, I cannot remember which!), do you have any other USB sticks of sufficient capacity to hold the Rockstor installer?

Failing that, perhaps you could create an installation CD from the ISO which might yield better results.

Aside from these, could you transcribe the whole error list, or photograph and attach it? This might help us to determine exactly where things are going haywire.

I’ll try using a different thumbdrive. So is there something wrong with my thumbdrive, or does that particular brand just not work for this. Because I have used it before to load ubuntu a few times. By the way it is a Verbatim Pin-stripe.

Yeah, that didnt work. It still gave me the error code. What should I do now?

Here are some pics of the error codes it was giving me.

 When I installed rockstor, from USB stick, on my scavenged mitx Intel DN2800mt motherboard (30GB msata, 4GB DDR3, Intel Atom 64bit, possibly same era as yours?) it would get stuck with errors like shown in these pics. My issue seemed to be the Anaconda installers kernel itself having issue with there being no 64bit imagination technology video drivers.

 What I did was take the 30GB msata ssd put it in my Elitebook 8570w and then installed Rockstor to the msata from there. At the first restart opportunity I then transferred the msata back to the target motherboard and had no trouble from there finishing the setup. Im a little fogfy on exactly when i did the ssd move.

 Been running that same configuration for 1+ year, changed pool drives, and added a cheap x4 sata pcie card. rock solid.
1 Like

Same shit with 3different USB drive. :frowning: