Can't activate subscription, error on software update page

Got following error:

  Traceback (most recent call last):
    File "/opt/rockstor/src/rockstor/storageadmin/views/", line 225, in post
      return Response(rockstor_pkg_update_check(subscription=subo))
    File "/opt/rockstor/src/rockstor/system/", line 260, in rockstor_pkg_update_check
      version, date = rpm_build_info(pkg)
    File "/opt/rockstor/src/rockstor/system/", line 134, in rpm_build_info
      bdate = datetime.strptime(dstr, "%Y %b %d")
    File "/usr/lib64/python2.7/", line 325, in _strptime
      (data_string, format))
  ValueError: time data '01:48:41 20 Apr' does not match format '%Y %b %d'

@Jorma_Tuomainen Hello again.

So this is a strange one. We have seen here on the forum some datetime issues but I don’t remember seeing this exact one re broken update page.

Take a look at for example:

And ensure that python-dateutil is installed:

yum info python-dateutil

There are a few more references on the forum to datetime issues so there may be some clues via those threads (Magnifying glass in top right of header in forum).

I’ve also just answered your Rockstor 4 installer build question via support email so that’s another potential work around.

Hope that helps.

It’s there, I just copied the activation key to the .repo file so it works :slightly_smiling_face:
(nothing to update though)

I’m going to test rockstor 4 on my offsite nas which I’m rebuilding now and update the main NAS later.

It’s installed.

Installed Packages
Name : python-dateutil
Arch : noarch
Version : 1.5
Release : 7.el7
Size : 343 k
Repo : installed
From repo : base
Summary : Powerful extensions to the standard datetime module
License : Python
Description : The dateutil module provides powerful extensions to the standard datetime
: module available in Python 2.3+.

1 Like

But no help, I already had locales as default etc…

Ok, fixed it myself. Tinkered around the code and noticed that returned centos. Changed it to rockstor in /etc/os-release and now it works.