Dev log for 3.9.2

So how is that we can update to the 3.9.2 release at this point? I am currently running 3.9.1-16, but I have seen that 3.9.2-3 was recently released. I know the update process has changed, as @suman mentions above, but I haven’t seen the instructions on how to update to the new release.


3.9.1-16 is the latest testing channel release. That turned into 3.9.2-0 stable release, but since then there have been 3 ‘hot fixes’ to the stable release.

It’s in the throws of changing currently, but you are still on the latest testing channel.

Hope that helps.

So if 3.9.1-16 and 3.9.2-0 are essentially the same build, shouldn’t the hot fixes that have been applied to 3.9.2 also need to be applied to the testing channel code?

Is there a process that I could manually patch/build in those hot fixes into my environment?

We are going to stop automatic packing and delivery of updates in the testing channel. The plan is to provide a documented(in the UI) alternative for non-subscribers(testing channel) to follow to get updates. Right now, we are finalizing these steps. If you are on testing channel, you will get one or more updates as we transition into this new way. If you really want updates in the meantime, your choices are 1) subscribe to stable channel or 2) figure out the manual steps yourself from available docs. This can be very risky, even if you have high levels of linux and programming skills.

@suman Has a plan been put in place yet for updates for those of us on the testing channel? It looks like the code base has moved on to 3.9.2-9, released 2 days ago.

We are lagging behind, but the plan is indeed in place. Testing channel subscribers should see a couple of updates in the near future which will update your UI with all the information necessary to keep your system up-to-date going forward.

@suman As there is no more a dev log for new releases here on the forum…is there a way to see the changes/updates that was done within a new release?
rockstor x86_64 3.9.2-11 stable was installed over night and I was wondering what is new :thinking:

Thanks -regards,

We’ll add a changelog link to the UI, but you can see what’s in each update by going here:

1 Like

@suman do you know if the testing plan is ready to roll out yet?

I like to keep my systems up to date (bug fixes, security, etc), so if the testing channel is being killed in favor of a paid only subscription, please let us know. That way those of us that are in limbo waiting for updates can make a decision on how to move forward.

@kupan787 Hello again

I can address this one:

All updates bar those of the rockstor package, the kernel, and btrfs-progs can be installed on either stable or testing channel at any time via the flashing icon to the left of the kernel version number (top right):


And given our kernels are unmodified elrepo-ml you have the option of adding this repo (via their instructions) to gain their updates as they come out or, as @jim.allum recently posted howto indicates:

to a specific version, until our next matching release of kernel and btrfs-progs is release. This is safer option as you are a little less ‘out on your own’.

Also see @suman’s recent post re kernel update:

Also all code is open-source and can be built from the GitHub repo via the instructions within the Developers section. Although this is non-trivial and there exists a caveat via an outstanding @Flyer pr:

which is trivial to apply. But note you may loose all settings / db entries so be careful on that front.

The plan is to transition the ‘testing channel’ away from an rpm based update to one where you can use the code published on GitHub the minute it is available. Ie as it’s merged it will be possible to initiate a rebuild directly from that code. This will server development better as there will be less delay to each testing release and less overhead to managing 2 seperate rpm update trains. So hopefully a win win, earlier and quicker updates as soon as is possible, for those who are happy with this more edgy approach, and more developer time spend on developing rather than rpm release management.

But unfortunately this is all taking longer than anticipated and is frustrating all round so please be patient as these things are always a little more involved than at first they appear. But the intention is to maintain a “value add” (probably stability/convenience based) to those on the paid subscription as that is an important element of Rockstor’s sustainability, along with Incident-Based support of course. Without these elements we could end up being another OpenFiler.

Note also that all updates to the Rockstor package in the stable channel subscription since latest testing release have been convenience and bug fix related. No security related fixes have been committed.

Hope that helps and let us know how you get on with that update everything else button provided by @Flyer, it is in keeping with all his other contributions, quite fancy: see also pincards password recovery system.

I have been running the testing channel, and after an update a little while ago to the last testing release I am having the problem where shares are not loaded on power up, which is obviously as issue for a NAS.

From what I read this is fixed i think in later stable builds, but is not fixed in the testing build (though I’m not 100% it is fixed in the stable build). At the moment I’m working around by going and executing a sequence of commands after a power cycle (enable quotas, restart the various rockstor bits).

At this stage I’m not sure if I need to sign up for stable builds just to fix my system (if it will even), or if there is another way to solve this issue? I can’t seem to see an actual ‘solved’ in the forums for this issue.

@Ivan Hello again and thanks for the report.

Not sure on this one as the main recent ‘not mounting’ issue was kicked off by a move in stable updates channel only to docker-ce which inadvertently disabled quotas which in turn caused us to have to deal better with no/disabled quotas which stable now does: via a series of ‘hot fixes’. But given you’re on testing the docker-ce move shouldn’t have happened yet. But you have apparently identified quotas as an element! Could you please open a fresh forum thread with your findings and any log entries (System - Logs manager, Rockstor Logs and Dmsg) that look suspect during a boot as it should then be possible to track down what’s going wrong on your install: make sure to include your Rockstor version. I’m not myself aware of any issues in testing that should cause this that are not quotas disabled related and unless they are turned off manually all pools should have quotas enabled, and it persists over a reboot (unless docker-ce is there to disable it for us; nice). But there have been quite a few significant improvements re pool, share, snapshot management/import/refresh that have been made so lets see if the logs can tell us anything in a focused thread.

Hopefully testing updates (in their new guise) will soon return and all stable ‘hot fixes’/improvements will be available via the testing update method (when it arrives) which is likely to pull straight from GitHub where all code is always available (tagged by stable release version) as soon as it is committed. The idea going forward is to cherry pick the best from development and release it ‘easy style’ to the stable channel.

Hope that helps.

We are now 3.9.2-17 but changelog stays at 15 - I would appreciate to follow what is new or has been improved, also to test and give feedback-> can you look into this and update the release page on github?


@glenngould I can jump in on this a little (I have probably dropped a ball on this one):

the pending git label of 3.9.2-16 would relate to the following:

and similarly 3.9.2-17 would be:

Where the git labels normally precede their rpm stable channel release counterparts.

Hope that helps.

1 Like

3.9.2-18 is now available. This stable release enhancement adds the much anticipated “Disable/Enable Quotas” capability. Thanks to @maxhq and @Dragon2611 for helping to inform this feature and apologies to all who have been waiting patiently. Quotas Enabled is still the default and recommended setting; but all functionality, bar share usage reporting (0 bytes), is expected to work with Quotas Disabled.

Please note that, for the time being, disabled quotas are still an Error state within our logs; but log spamming re “quotas not enabled” should only be expected during Web-UI activity. We can revisit these behaviours going forward.

A quota rescan is automatically initiated for a given pool whenever it’s quotas are re-enabled. Please expect around 1 minute / TB of data for the share usage figures to return to normal. As always there are improvements to be had. Feel free to start a new forum thread with the details of any issue you experience.

Quick Howto prior to docs update:


Click - Select (from dropdown) - Tick to confirm.

Page refresh for current setting. See ‘mouse over’ tooltip for use context. Setting will persist over a reboot / power cycle.

This inline edit widget is available on both the Pool overview table (as indicated) and on each Pool’s details page.


This is a really nice feature @phillxnet!

Just to give it a go, I spun up a VM installed from the latest ISO (which is a few versions old btw). I then let that update to the latest testing channel (3.9.1-16). I then gave it a go doing an update from a git clone of the master branch.

I noticed that once I ran through everything, my install was no longer running out of /opt/rockstor but was running out of my build directory (in my case /src/rockstor-core/src/rockstor). This did indeed cause me to loose all settings.

The good news is that my disks were detected, so I reimported those (which brought back all my pools, shares, etc). I then restored a config backup I had taken. Everything seemingly came back up, except for my RockOns…need to spend a bit more time to find out why that service won’t start.

The bottom line is it seems to work just fine. The only thing I noticed is that the version info at the top of the page still shows as 3.9.1-16 instead of the latest 3.9.2-18. However, I do see the latest changes (like the Quota changes just made). So it is probably just a setting file some place that the version string gets read from?

I’ve yet to try this on a live system. Need to work up the courage for that :slight_smile:

@kupan787 Well done on the successful build; so are we to expect imminent code contributions :slight_smile:

Yes, that works purely on rpm so it would seem you still have an installed rpm version of Rockstor. We used to remove the rpm via the build process but these days it’s left. Probably need to add a warning to the dev docs on this one (do you fancy opening a rockstor-doc issue on this one). I usually uninstall that rpm prior to setting up a fresh dev system. Anyway as such there is no version information for the source build, it just errors out in the logs as an unknown version and nothing is displayed in the top right of the Web-UI. Might be nice if it could fail over to looking for a git tag or something and indicating the tag reference and that no rpm was found.

I’d re-do on your test setup first re the rpm install as you effectively now have 2 versions of Rockstor installed which is sub optimal and prone to confusion.

Keep us posted and thanks for further verifying the master branch build process.

I’m a developer by trade (specifically around SQL, BI, and data warehousing), but have limited exposure to web dev (just a bit in C# and JS). Now that I got a dev VM up and running, maybe I’ll take a look at the open issues and see if there is any low hanging fruit I can help out on. :slight_smile:


Hey everyone,
I’m no coding / linux professional so I do not understand many thinks you’re doing…
Unfortuntely my machine is still running version 3.9.1-16 which is about six (!) month old. The only postings in the forum I can find is that you’re trying to change the way the updates were rolled out/packed. So far so good…
How is the process running? There is no current documentation. Rockstor-Docs were mostly two years old.
Am I misunderstanding something or do you try to force all testing users to pay for it? Which I would truly understand…
I already saw that I can download the updated code from github which is like 3MB. Okay, but how can I update my system with this?
If you want a more commercial product it would be fine for me, if the prices will not raise much more. But I think you should make it clearly known / understandable.
Thanks in advance & happy easter

1 Like