Emby plays hard to reach

Hi this is my first post. I installed the emby rock-on following a youtube video. It worked at first but I had to do it all over because of hardware/hdd and my learning curve issues starting with rockstor system went south. I got the rockstore working again and when i finished installing emby rock-on with the following parameters.

Trying to start emby UI, either from inside Rockstor webui or thru chrome, it will allways give a “refused to connect message” I am not a Linux user, just very basic commands by I searched and found this:

The message ‘Connection Refused’ has two main causes:

Nothing is listening on the IP:Port you are trying to connect to.
The port is blocked by a firewall.

So,it seems that the default emby port :8096 is not listening, Therefore, I tried the command,

netstat -tnlp | grep :8096

and nothing got reported, which indicates that no process is listening.

About the firewall I don’t know much but I still think that’s not the problem.

Hope this helps.

1 Like

@undertakerjimmy love your title :slight_smile: and to be honest your linux is not that bad - you’re still here without smashing the screen with the chair :smiley:

Sooooo …

  1. have you altered any default parameters during a default install ?
  2. Does a rockon actually start properly ?

If in doubt you can always remove all rockons, disable the rockon service (and point it to different share) and delete all shares assosiated with rockon & Emby.

That way you will start fresh.

Thanks for your reply. Solved the issue. (I only posted when I started to get frustrated.)

Tried to uninstall the rock-on and reinstall shutting down the system in between. Did a port scan and emby ports did not appear. Tried to check for emby process but could not find any (they might be there just could not find them) Tried searching to install it with out rock-ons and learn something, but then I decided on another approach before attempting to install emby the old fashion way.

This is what I did;

Tried the backup function, and worked well!!
Re-installed rockstor yet again, which I’m becoming an expert.
Did not do yum update --that, I saw in a video on how to install rockstor
Restored the shares, and applied the config backup file.
Started the services … samba and rock-ons
Finally re-installed emby rock-on and this time instead of typing the group name emby I typed 1001 for the GID

THEN BINGO Its alive and works!!!

Two things

First, it may be premature to say rockstor is a keeper, (for me) but I think the stable updates are the way to go with me, and that’s next. Its the least I can do for your efforts.

Second, the emby server needs and it’s asking for a manual update (i know how to this in windows) but, if yum update messed my system I am at a loss here. Documentation does not mention anything about how to update emby rock-on. I believe a new topic is in order since this is a different issue.

Please advice and take a stab at what happened before. Thanks

1 Like

Glad it’s working now @undertakerjimmy !

To update the Emby Rock-on, you can follow the instructions on the docker hub page.

Personally, I do it manually on the command line with the following:
``` docker exec embyserver update`

Contrary to what is mentioned on the page I linked above, the name of my docker image is embyserver and not emby-server but you can doublecheck that by running docker ps on your own machine.

Depending on the update and hardware, it can take up to several minutes but it works.

Hope this helps!


You people are great. @Tomasz_Kusmierz ,@Flox.

I did;

docker ps

to check for service name,

docker exec embyserver update

then lost web-ui and emby-ui , rebooted a couple of times and did more searching and a found a post by @Flox that shed light ad applied his solution, restarting rockstor from the console; (Can't access Web UI (newbie) - #2 by Flox)

systemctl status -l rockstor

this showed that rockstor was active but still I applied;

systemctl restart rockstor

and It all went to normal.

Now, I question if I have to do this with every emby update?? I will tell when the next one comes along.

You shouldn’t have to reboot after updating this Rock-on (or any rock-on for that matter, I believe), but you also shouldn’t loose the web-ui after doing that… It may highlight a more substantial problem, but make sure to wait for quite a bit after updating the Emby rock-on. In my case, the emby web-ui is not reachable for several minutes after updating it as it takes quite a bit for the docker image to be restarted. If following 5 minutes after the Emby Rock-on you still can’t reach it, then I would check what happened with the emby rock-on startup process.