Got a few Services Running on Rockstor (Dropbox, Pi-hole, Plexrequests, etc)

Just a short update.

Today I reinstalled after having deleted the share.

Pi-hole is working as expected now.

Only problem I see is this:


Where before it would show version numbers it now shows N/A.

Perhaps this means I’m uptodate?

Interesting… Perhaps you could confirm by using the built-in pi-hole command?

docker exec <pihole_container_name> pihole -v

There is still something funny going on:

Since my last post, the web-ui has started to show this:

Running your command, with the relevant container id gives this:
docker exec 896b168d7c80 pihole -v
Pi-hole version is v3.3.1 (Latest: v4.0)
AdminLTE version is v3.3 (Latest: v4.0)
FTL version is v3.0 (Latest: v4.0)

So it seems I’m not on the latest version.

Its definitely a different (and improved) version, from what I used before the update, but I do wonder why it doesn’t install the latest version?

I’ll try running “pihole -up”, and see what happens :slight_smile:

pihole -up
Function not supported in Docker images

Something seems to be wrong anyway.

The Rockon status page shows this:

Even though Pi-Hole is up and running. I can start and stop it via SSH, but the web interface seems broken.

Hi @KarstenV,

What happens if you follow the steps in the “Upgrading” section of: ?


I tried the steps from the “Upgrading” section.

That went wrong, and I hosed my pihole setup. Probably because I did not now the correct args…

Used the RockStor webinterface to uninstall and reinstall, and I have it working again.

If no easy upgrade path is available, I’ll leave it as it is.

Interesting… I second @vesper1978’s suggestion as the container’s doc does mention that the pihole -up command is disabled on purpose (to follow Docker’s way of updating).

It seems the new image for the container was not pulled docker pull pihole/pihole, which leads to wonder whether Rockstor tries to pull a new image of a container when re-installing a Rockon (uninstall followed by install). Does anybody have insight on this? I’ve always done these updates manually at the CLI so I can’t remember what happens when doing so from the web-UI.

EDIT: I should have looked up this thread and noticed my question was already answered above:

Hi @KarstenV,

Can you provide the output from:

sudo docker images | grep -i pihole


sudo docker images | grep -i pihole

pihole/pihole latest 9a1363998a45 2 weeks ago 345MB

You seem to have the correct image… as I have the same upon a fresh image pull:

docker images
REPOSITORY                       TAG                 IMAGE ID            CREATED             SIZE
pihole/pihole                    latest              9a1363998a45        2 weeks ago         345MB

I’m not on my Rockstor machine right now but under a test Ubuntu install, I started a new pihole container manually and seem to get the V4 version:

$ docker exec -it pihole pihole -v
  Pi-hole version is v4.0 (Latest: v4.0)
  AdminLTE version is v4.0 (Latest: v4.0)
  FTL version is v4.0 (Latest: v4.0)

You could try re-installing again after cleaning the image up manually:

  1. Turn Rock-on off on the Rockstor webUI
  2. Pull new image: docker pull pihole/pihole:latest
  3. Uninstall Rock-On from webUI
  4. Verify the container has been removed manually: docker rm <container_name> (replace <container_name> by what is shown when you do docker ps -a. If you don’t see any pi-hole container, you’re good to move to the next step. If you do see a pihole container, run the docker rm command above.
  5. Remove image (overkill, but just to make really really sure you get the latest): docker pull pihole/pihole:latest
  6. Re-install the Rock-on from the webUI using the same pi-hole config volume.

If @vesper1978 agrees these look ok, I would give that a try.

Looks to be the right image.

I probably should have had you run:

sudo docker images | grep -i hole

since it looks like the old docker repo was “pi-hole” and not “pihole”.

I suspect your container is probably based upon an image from the old repo.

If you do:

sudo docker ps -a | grep -i hole

You should get a list of your containers (running and stopped) and what image that container is based upon.

I suspect you will have a running container that is based upon “diginc/pi-hole” and not “pihole/pihole”

I actually seem to have both of them, but with the diginc one being active.

sudo docker ps -a | grep -i hole
4d8161698942 diginc/pi-hole “/s6-init” 5 hours ago Up 5 hours (healthy)>53/tcp,>53/udp,>80/tcp,>80/udp, 67/udp, 443/tcp pi-hole-diginc
87bfb196cc02 pihole/pihole “/s6-init” 5 hours ago Exited (1) 5 hours ago reverent_cray

How do I get the new one activated?

I would follow the steps I detailed in my post above to reset everything.
On a side note, I wonder why the “Pi-hole/Pi-hole” container didn’t get a proper name. According to the JSon, it should be Pi-hole, and not one randomly generated by Docker.

@Flox I think your steps look good and should remove any conflicts at least.

I have now tried re-installing after cleanup, following the steps @Flox detailed.

Everything went smooth, and Pi-Hole is running again.

But still I’m getting this…

docker ps -a
dd11f142c4db diginc/pi-hole “/s6-init” 38 seconds ago Up 37 seconds (healthy)>53/tcp,>53/udp,>80/tcp,>80/udp, 67/udp, 443/tcp pi-hole-diginc

And this…

docker exec dd11f142c4db pihole -v
Pi-hole version is v3.3.1 (Latest: v4.0)
AdminLTE version is v3.3 (Latest: v4.0)
FTL version is v3.0 (Latest: v4.0)

What in the world am I doing wrong??? :slight_smile:


You’re doing nothing wrong as far as I can tell. The Rock-On registry’s master branch has not been updated with the official Pi-Hole docker hub repo.

Perhaps someone else can provide details as to how to force Rockstor to use the Official one until the pull request to merge it into master goes through.

You need to copy the JSON file for the official pi-hole and load it into Rockstor as detailed here:

After clicking the “Update” button on the Rock-ons page, I believe you should now see two Rock-ons for Pi-hole. This is where I’m unsure of what you will see, however. There may be two of them with the same or different names as follows;

  1. Pi-hole-diginc
  2. Pi-hole

Look at the description text, or the “help text” when hovering the little “information” icon to help differentiate the two in case they show the same name.

1 Like

Thanks for all the help guys.

I think I’ll just leave it as it is.

Pi-hole is working, and I have somehow gotten used to the fact that Rockstor is slow to follow the new updates.

It works well, so I’m not too worried. Allthough it would be nice if things like the kernel (for e.g. security reasons, and btrfs updates), and Rock-ons were kept more uptodate.

Hi, I’ve been away for a while. I tested the updated json file locally (as it would not show up in the regular repo for me, have to check that out). It installed fine from the new repository - but I did need to remove the config share and create a new one, otherwise it was referencing an old version that I seem to have zombie’ng around on my system.
After the install and upon launch of the WebUI I also saw the N/A entries for version etc. at the bottom. However, as soon as I logged into the console via the menu, the version fields were populated, like so:


So, not sure whether that helps or not. Now, I just need to clean up the three old images I still have sitting on my box :slight_smile:

1 Like