Kernel panic after upgrade to 3.8-10

My NAS is running the stable channel, I just upgraded to 3.8-10 and it no longer boots.
After updating was prompted me with:

You are running an unsupported kernel(4.2.2-1.el7.elrepo.x86_64). Some features may not work properly. Please reboot and the system will automatically boot using the supported kernel(4.2.5-1.el7.elrepo.x86_64)

So I rebooted, when I get this selection…

Almost immediately after that, I get this error:


Choosing the old kernel makes it possible for me to boot it. But I’m afraid if I get another update in the future, this old kernel won’t be an option anymore, so a fix would be nice :smile:

If there’s anything I can help by sending, please let me know.

As I am a new user, I was not allowed to upload multiple images. Allow me to post the second image via replying to my own post:

Hi @rayburgemeestre! Welcome to the Rockstor community.

Do you mind sharing your hardware specs?

Have you tried booting a few times? and get the same error every time?

Finally, it’s OK if you stick with 4.2.2 for now. You can ignore the warning as the diff between 4.2.2 and 4.2.5 is not much. In order to stay reasonably close to latest btrfs changes, we update kernel often, though it’s undesirable because of consequences like these. Hopefully the frequency will decrease in the near future. If your hardware is not supported by the latest, you can stay behind a bit.

Hi Suman,

Thanks for your reply, I will keep it at this version.
Next time I update I will just create a backup for the root filesystem so I can revert it if necessary.

These are the main components my NAS is build from:

(removed some less important parts because of the max of 2 links per post, if you wish for more info please let me know)

The disk for / :

Model Family Seagate Barracuda Green (AF)
Device Model ST1000DL002-9TT153
Serial Number W1V0FJDA
World Wide Name 5 000c50 038d33b22

I realize this is not something you guys can do much about, so no problem if this topic gets closed or deleted
Thanks again

@rayburgemeestre Thanks for posting the hardware info. All I can suggest is that you simplify the system as much as possible ie disable elements / functions in the bios that you are not using ie sound card etc in the hope that one of those is the cause of the kernel panic, seems unlikely to be sound card this early on though. And unplug any add-in hardware that is not required. Just a though.

I think it’s good if we keep track of such things so that your experience and reporting of the same can help others see it’s not just their systems. Keep us posted if you make any headway. Hopefully this is just a regression and that newer kernels, as Rockstor adds them, will work for you again.

Hi Philip thanks, I will keep you guys informed with future Updates. :grinning:

I’m getting exactly the same on my Dell Inspiron 530. When I reboot with the previous kernel, it seems fine. It’s a Q6600 quad core Core2 with 8Gig RAM. All built in features (LAN, audio etc.) are disable. It does have 2 x 1Gbps ethernet cards and a RAID card (6Gbps). Boot drive is a WD 2.5" plugged directly into the MB. Then there’s 2 x 6 TB WD drives on the RAID card.

You are running an unsupported kernel(4.2.2-1.el7.elrepo.x86_64). Some features may not work properly. Please reboot and the system will automatically boot using the supported kernel(4.2.5-1.el7.elrepo.x86_64)

Thanks for reporting this @Patrick_Martin. As you’d understand, it’s hard for us to ensure hardware compatibility as we all run Rockstor on a large variety of hardware. You can ignore the warning. If you want to remove the warning and make an older kernel default, see this post.

I hope that with 4.4, we could stick to an LTS kernel and not have to change often.

Slightly OT, but I encourage those of you that are getting a bit deeper into BTRFS to report problems on that project’s mailing list, which could help out BTRFS developers.

Thanks. I worked in QA for a long time. It’s pretty hard to ensure compatibility. However, there’s nothing new or unusual in this system other than the RAID card. Everythign else is circa 2007 off the shelf Dell stuff.

FYI, running on the old kernel I get the attacked message. Not sure if the kernel version is the reason?

I have exactly the same problem with kernel panic after download newest iso, install it on esxi 5.5 and upgrade to newest version from bultin upgrade feature.

I also have no trouble with 4.2.5 but kernelpanic at boot with that newest unstable build (10-17)

I’m also having this issue now. I cannot boot using anything but the 4.2.5 kernel. Hardware specs are commodity desktop hardware from 4-5 years ago: Intel q45 chip with 6GB RAM. NIC onboard and WD Red disks - nothing special.

Have there been any workarounds or solutions floated since this issue began occurring? I just purchased a license for the software so as you can imagine it’s a little annoying encountering this immediately after purchase.

I assume that by doing a backup via the UI and maintaining my existing disks and pools, reinstalling on new hardware without any content loss should be pretty straightforward?

Edit: wrong - q45 is from '08. Small clarification.

Is anyone here booting off a USB thumbdrive? I think there was an issue with newer kernels, not sure if it has been resolved…

I run off a USB drive, which forced me to boot into 4.2.5 and it has been running really stable for the past month I must say. (Knock on wood) I think I saw exactly the same message as the OP.
Will try to upgrade and reboot once I have physical access to my rockstor machine again. Should be next weekend.

Any update here by any chance? I just built out a new system and I’m attempting to boot 4.3.3 from USB and having the same issue - kernel panic unless I boot into a 4.2.5 kernel.

At least on testing channel, there is an updated kernel (4.4.5) available, boots fine for me…

Just switched to the stable from testing, got kernel panick after a reboot. Same issue as described here. Reboot gave me the old kernel to boot from and that resolved it for now, but permanent fix would be nice since now Rockstor tries to launch into the broken kernel version.

There is also an error in the ‘software update’ screen now: You are running an unsupported kernel(4.2.5-1.el7.elrepo.x86_64). Some features may not work properly. Please reboot and the system will automatically boot using the supported kernel(4.3.3-1.el7.elrepo.x86_64)

Running a C2750D4I motherboard.

Edit 05/05/2016: Upgrading to 3.8-13 fixed the problem, kernel running now is Linux: 4.4.5-1.el7.elrepo.x86_64.

Good news from me too! Damn finally the Rockstor UI is responsive, for Months I had to wait minutes before a page was loaded, glad stuff is running smoothly now :slight_smile:

So I didn’t check stable, because I switched to testing at some point.
Updating didn’t work via the UI (after 5 minutes, simply nothing happened).

Then I executed yum update rockstor via commandline, and that worked, but I had to issue a yum update kernel separately in order to get the new kernel too.

Running w/Kernel Rockstor (4.4.5-1.el7.elrepo.x86_64) 3 (Core)


1 Like

Well, I think I hit this bug too, this is all I did:

-Installed rockstor stable 3.8.13, moved my data, configured some rockons and upgraded to 3.8.13-14. My machine freezed and had to reset it, didn’t payed more atention to it, On reboot loaded new kernel and panicked. Loading old kernel and back to business, tought that I’ll take a look into it later…

  • Today new release to test, upgraded and everything went fine. Rebooted but… panic again. Seems related to the system not being able to find the boot partition… or whatever…

My system is an HP Microserver G8, old kernel works well under heavy load (tested). Booting from an SD card seen by the system as an USB mass storage drive.

Any clue where to go from here???

Attached are two images, one with the core kernel and the other with the debug one…

Replying myself, fixed it with the following steps (not sure which one did the trick, or if them all together). Found several possibly related topics in archlinux and centOS blogs, sorry I lost the references.

  • run ‘yum update’ just in case, and found the btrfs utils pending to update, which I did
  • run ‘ym reinstall kernel’ to force the latest kernel to reinstall. This took soooooooo long, so be patient
  • run ‘yum check’ as it sounded good to check everything just in case… This one also takes a long time, appears to do nothing but CPU usage, almost no disk activity, but let it run…
  • still had a strange warning spitted out from yum, something related to an uncomplete transaction and telling me to run yum-complete-transaction to fix it. Installed yum utils and run the aforementioned command that reported 0 actions pending from 1 open transaction. Look like it did ‘nothing’ but took the warning away, good for me.

Rebooted and everything’s working on latest kernel, cooooool!!! For the lazy ones, these are the commands I run in its right sequence, as far I remember:

yum update
yum reinstall kernel
yum check
yum install yum-utils
yum-complete transactions

Reboot and enjoy your latest kernel…


I am also a Dell Inspiron 530 user, facing same issue of no longer booting in my system. I use this method from Dell Inspiron 530 Manual to resolve my issue:

  • Press + after the Dell Logo appears.

  • once the Manufacturing Mode screen appears just follow the onscreen instructions to proceed.

  • If it prompts for you to enter a number for the Management settings (Intel AMT)

  • To ensure the Manufacturing Mode has been reset, please shutdown the system and turn it on again to check it boots up.

1 Like