Multiple rock-on issues

I am having a few issues with my rock-ons.
First, I have a rock-on that is stuck in “pending_stop” in the GUI. I have uninstalled the rockon and it is not visible with a docker ps from the cli. I have also removed the image from the cli, yet the GUI still shows it stuck in the stopping state. Is there a way to correct this? I have tried stopping the docker service, rebooting, etc. with no effect.
Second, and it may be related, my plex rock-on is not updating. I have tried stopping the rock-on, running the update, and restarting, but it is still stuck on an older image. running docker images from the cli shows multiple linuxserver/plex images, one from 2 years ago and one from 2 weeks ago, but for whatever reason the older version is what seems to be running.
Any help would be appreciated.

Hi @wgs,

Let’s see if I can help with that.

That looks like some issue with synchronizing the database. I would suggest to run the following script that we have to reset the database info for this rock-on. It will also delete the container if it still exists. This way you can re-install the rock-on using the same shares as before (if you want to re-install it) and you will be in the same state as before/

Briefly, you would need to do the following:

 /opt/rockstor/bin/delete-rockon <rock-on_name>

The <rock-on_name> is case-sensitive, so make sure to verify lower and upper cases. If the container name includes a space, place it inside quote ("Rock-on name with spaces").

Then, in the web-UI, refresh the Rock-on page (F5), and then click on the “Update” button in the top right. This will re-fetch all rock-on information and update the database accordingly.

I’m not sure if you mean exactly by “running the update”, but for the Plex rock-on, I believe it should check for update and update itself when the container is started. As a result, turning the rock-on OFF and then back ON should do the trick. The usual procedure to update docker images, however (and rock-on as well), would be to stop the rock-on, uninstall it, click the “Update” button on the rock-on page to refresh all database information, and then re-installing it using the same shares. This would then pull the latest image available.

Let us know how this goes, and I hope this helped!


On the Plex Rock-On I can second @Flox’s statement. That image stays at the “original” installation date. However, because it’s a image it goes through its own update process for the plex version. If you used the version label “latest” during the initial install:

it will look for the latest version, whenever you stop and restart the rock-on. When you look inside Plex it should then show the latest version in the Plex WebUI:
Before the Rock-On stop and restart:

After restart (which then takes a little bit longer for an update to be pulled):

but the image itself still shows when it was originally installed (I reinstalled the RockOn 2 months ago)


Thank you both for the suggestions. delete-rockon fixed the first issue. For plex, I ultimately did a reinstall before I saw the message to check for latest and that worked pretty seamlessly.