New NAS build & Rockstor 4 install

I’ll post about the NAS build later, but I had a very easy install of Rockstor 4 using the installer recipe. Created a pool and a first share, went to set the access credentials for my user and kept getting “passwords don’t match”. I spent quite a while retrying, and a different password, always the same result.
The only reason I can think of: if the user is one I set up as an admin, will it be matching the share access password to the admin pw? It shouldn’t matter as I used the same pw, but tmw I will change the admin pw and see if that fixes things. But is this an identified issue?

@ceh-u Hello again.

Password duplication between users is not a problem as under-the-hood they are all hashed and salted so don’t end up being the same. All as per regular user use on linux/unix. You should also be able to use the admin user to access your shares if that is the way you want to go. Probably better to setup a different user though and make sure they have access to the share. That way you leave the Web-UI admin user for just the Web-UI.

Share access permission setting is covered in the docs in for example the Plex Shares howto.

Funny this though as your test in a VM earlier did not show the same issue.

So take care to get your user share access lined up. Users can always access shares they own and the users you create in Rockstor are the regular linux users. But the Admin user has special Web-UI access setup by default.

Hope that helps and good to here you have your ‘real’ machine up and running. All be it with some teething issues. I’d be tempted to setup as you did with your successfully installer in the VM to ensure we don’t have a new issue emerging. Also if accessing from OSX take heed of it changing user name case etc.

OK, I’m going to write up a proper account of my NAS configuration and installation experience, but all goes very well so far. Solved my password problem - minor detail.

I am a Mac user, and I have Time Machine (about 3TB) plus I keep all my important user files on Microsoft’s OneDrive, which comes with Office 365. So initially I’ve changed Time Machine to use a share on the NAS for its disk. I’ll also, to start, copy my user files from OneDrive to a Samba share and use them there, and once I’m completely confident with how it’s all working I could delete the OneDrive folder, saving about 100 GB of disk space on my iMac. It would be great is the official OneDrive folder could be in a NAS share, but it seems Microsoft doesn’t support that. Some other NAS systems have features for doing it.

So I’m getting thing set and exploring. One issue with my UPS that I’ll explore to see if there is other experience that will help.

Here’s the details about my first NAS Server, put into operation this week,

Case: This is important for me, needed plenty of drive room to allow for growth, A1 cooling, not too bulky and reasonable looking. The Fractal Design Node 804 ticked all those boxes

Node 804 — Fractal Design

Its an mATX cube, 2 chambers, 3 very quiet fans, accommodating up to 8 X 3.5in HD & 2 X 2.5in. It was really easy to build in. It’s fairly expensive, but I didn’t find anything that fit better. And it is visible in my office, so its look are good.

Motherboard: Needed to be one that would last a few years, supporting component upgrades, support up to 8 SATA drives, support decent CPUs and memory. I read about about a bunch of boards, narrowing down to Asrock Rack and Supermicro. At the time I was buying, COVID was restricting supply in Australia, so I looked at several Supermicro X11 boards before finding the mATX X11SCL-LN4F. It supports the Xeon E-2100 & 2200, 8th/9th gen Core processors, up to 128GB of UDIMM ECC memory, 6 x SATA 3 (more can be added with mini SAS connections), a huge number of LAN ports, VGA, etc.

CPU: Intel i3-9100F (no graphics). This came with a CPU cooler which seems quite sufficient for now.

Drives: for the system, I had a 120GB M.2 with PCIe 3.0 x4 interface, which the X11 requires. For the drive pool, I got 3 x Seagate ironWolf 4TB NAS drives. These accounted for about half the total cost.

The build was a snack, with plenty of room in the 2 chambers and few components.


For the software, I followed the Rockstor 4 Installer recipe in the forum, which is very clear and straight forward. That produced an installer that I used first to install in VirtualBox, and then unchanged into my NAS. There are absolutely no issues, apart from a minor password glitch I created. There is also an issue to sort out in the NUT-UPS, as mine was filling the CLI every second or or so with technical messages and a statement that UPSlocalhost was unavailable. I now have the NAS running, absolutely silent, with a raid 5 pool and 2 shares as I previously posted.

The Raid 5 decision: I’ve read acres of reviews and articles about Btrfs and ZFS, and the Copy on Write feature is a major step, according to the experts. I know Btrfs has the risk of a write hole if the server goes down unexpectedly. But I have a very good UPS serving the NBN fibre-to-the-premises termination box, my router and the server. I’ve read statements by several users who’ve run Btrfs Raid 5 without issue for years. So I’m prepared to take the risk. In the worst case, I’d go to ZFS which is excellent except for the inflexibility in the sizing of its drive pools, and the cost of increasing the capacity by replacing every existing drive.

So, I’m extremely happy with the hardware and the software, and I congratulate Philip and his team of developers for such a sound product.


OK, I haven’t been able to find any solution to my NUT-UPS issue. When I connect the UPS via USB, it constantly outputs the messages in the attached photo.

I’m not sure if that upload is working, so the messages are:
hid-generic 0003:0764:0501.00D3: hiddev97,hidraw4: USB HID v1.10 Device [CPS UPS VALUE] on usb-0000:00:14.0-1/input0
usb 1-1: USB disconnect, device number 90 (that number increases with each message set)
usb 1-1: newslow-speed USB device number 91 using xhci_hcd
usb 1-1: new USB device found, idVendor=0764, idProduct=0501
usb1-1: new USB device strings: Mfr=3, Product=1, SerialNumber=0
usb 1-1: Product: UPS VALUE
usb 1-1: Manufacturer: CPS

These evendor and product Ids are correct; it’s a Cyber Power BR850ELCD; I have the driver set at usbhid-ups, which is listed for all Cyber Power UPS that use USB connections.

One other issue that came up when I was looking at the Drive page; I didn’t see anything unusual there, but this message box popped up and I couldn’t get rid of it till I closed the web view. The UPS-related background is just because I moved to that display before I took the screen shot.


In case that doesn’t open, it just says: "Data Tables warning: table id=disks-table - Cannot reinitialise Data Table. For more information about this error, please see 3. Warning: Cannot reinitialise DataTable.

@ceh-u Hello again.

We have 2 unrelated issues here. The NUT ups issue and the data tables.

For the NUT issue you can sensibly search NUT (Network Ups Tools) related web entries for your issue as we make pretty generic use of NUT under-the-hood. We simply pop a Web-UI on it. Though we may well have a bug there so keep that in mind. But whay you are seeing may have a generic fix which can either guide your configuration used via our Web-UI element or guide an improvement we need to make to acommodate. But in the interim, you might also want to post your configuration page.

The second unrelated issue is the DataTables thing. Just use the browsers refresh button. This may be caused by a bug in our likely old DataTables version or in how we use it. We have in the past reduced the occurrence of this web tech bug but not completely removed it. What we need is a reliable reproducer so we can open a new GitHub issue with that reproducer so we can be assured of having fixed it. It’s mostly seen these days after long back and forth between various pages, but as stated the simply work around until we have a reliable reproducer is to just use the browsers refresh button. This reloads the state of the web page that is our Web-UI and all is happy again for a bit.

Oh and nice to see the build coming along by the way. And nice case. I’ve a couple of cheaper generic desktop Fractal Design cases here myself. They were actually very nice for what was pretty cheap by comparison with it’s like.

Hope that helps and let us know how you get on with that NUT issue. And make sure to post your actual config used as that may help others help you with your particular config. And I seem to remember someone suggested you might need a udev rule for that model. See @thedrjones post in response to an earlier build thread of yours:

Might be a good place to start at least. Just keep a note of all you change so you can backtrack if need be, and check that the systemd services referenced there are named as per the openSUSE variants also.

Hope that helps.

1 Like

Hi - re UPS, I did extensive searching, and I did review @thedrjones kind advice. The information that is being spit out is almost exactly what he suggested, except for the final TAG+="systemd’ and the ENV{SYSTEMD_WANTS}+= parameters. My configuration is stock standard:

UPS is pretty important for me, being a protection against system crashes which could kill my Raid pool. I will have another shot at adding the NUT-UPS rule, but I’m not optimistic. Cyber Power UPS likes the PowerPanel Personal app which I have used in macOS.

OK, pity you can’t see me eating humble pie!! After about 10 minutes work I managed to key the exact text provided by @thedrjones into a file with nano. Problem was, even when I switched to my good moshi keyboard, the " double quote wouldn’t enter. I found that if I hit that, then ’ single quote it would sometimes go in. But spurious ’ kept appearing. Anyway, saved the file where he advised and rebooted. Until I was able to log in and turn on NUT-UPS (didn’t think to do that before), the messages were still coming. Now they are GONE!

So I’m a happy camper again. My Time Machine backup (700GB++) finished this morning (started late yesterday afternoon) and my OneDrive sync is in process