Opensuse Backports Repository Expired

Couldn’t find an existing post specific to this one, but I have started getting an expired metadata for the back ports;

Anyone else?

I’ve had the same message since 2/5 as well. It still provides the kernel updates. Reading on some OpenSUSE forums, this error message also can mean that nothing has “changed” in the repos that requires the update of the metadata. I’ve seen that before in some other repos, and it was eventually fixed.
Looking at the repo online, all time stamps are recent, including the repomd.xml and keys, etc.
So, for now just a warning, but should not have material impact, and it’s something that upstream needs to address …


Thanks @Hooverdan I kinda had an inkling that might be the case. Good to get confirmation, thank you.

openSUSE Leap 15.4 - is expected to be maintained until end of December 2023 so guess it’s time for upgrade to 15.5?

@GeoffA & @Jorma_Tuomainen Hello again.

We have been building & releasing rpms on/for 15.5 since 4.5.8-0 through our last stable releases of 4.6.0-0 & 4.6.1-0 and are now focused on 15.5 as our next installer release base OS, possibly quite soon; given testing channel updates is now at Stable Release Candidate 3 (RC3):

And we have recently made a few installer updates over at:

such that all 15.5 profiles are now expected to work with a default installer build (currently using the latest as of writing 5.0.8-0 testing rpm).

But we have yet to see a 15.4 to 15.5 addition to our ongoing series of in-place distribution update how-to s to follow on from the existing:

However they are aimed mainly at stable release instances, and we are not quite there just yet given the outstanding (and to an extent in-flux) issues remaining in our current GitHub Milestone of:

Hope that helps, if only for some context.


Yep, I’m running stable on my primary NAS and testing on my secondary off-site backup.

Mainly inquiring my chances to have working system if just doing the same as with 15.3 → 15.4 update?

@Jorma_Tuomainen Hello again.

You should be good on the testing system (if fully updated to most recent 5.0.8-0) as all code is much newer, and so now properly adapted to 15.5, without having to maintain older dependencies that only existed in 15.4; and that are still required by the existing stable rpms.

We also have the following reassuring post from @agjbond007

Hope that helps, at least for some context.