Postfix problem

Hello all,

has someone working email notification on rockstor 4.0.4?

I did try several smtp outgoing servers (both linux and windows server) and it is not working as is.

Postfix eror:
postfix/smtp[5199]: warning: SASL authentication failure: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (No Kerberos credentials available (default cache: DIR:/run/user/51/krb5cc))

This means the remote server and rocstors postfix negotiated KRB5 authentication (or another digest mechanism sometimes) that it is not working.

As a temporary fix I added this line to /etc/postfix/
smtp_sasl_mechanism_filter = plain, login

It is working now.

What is your experience with email notification on Rockstor 4.0.4?



Hi @kri164, and welcome to the community!

Thanks a lot for your report, that’s very informative.

Personally, everything is working fine for me using a gmail account as outgoing smtp.

Thanks a lot for sharing your solution to your issue; I’m unfortunately not familiar enough with postfix to be able to provide feedback on whether or not it needs to be implemented into Rockstor, but others here will.

I can provide a bit of history, though, as the last changes we had on postfix was released in Rockstor 3.9.2-54, which included the following fix by @phillxnet:

This contained a series of fixes to bring our postfix implementation to compatibility from our legacy centOS base to our new openSUSE base.

Sorry I cannot be more helpful than that at the moment, but hopefully others will be able to chip in.

1 Like

Hello Flox,

thank you for info.

I have another question. On pure OpenSuse Leap the file postfix generic table has this file permissions:

opensuse # ls -al /etc//postfix/generic
-rw-r–r-- 1 root root 10221 Jun 9 03:35 /etc//postfix/generic

while on Rockstor the file permissions are:
rockstor # ls -al /etc/postfix/generic
-r-------- 1 root root 52 Nov 23 23:52 /etc/postfix/generic

Is there any reason for change of file permission or is it a result of script with wrong umask settings?


1 Like

Ooooh, very good question… If we look at the PR to which I linked above, we can see that @phillxnet actually spotted some erroneous file permissions in this one and fixed the way it was done. In particular:

So I would say this is intentional… Have you noticed a problem with such permissions? If so, we’ll have to discuss that with @phillxnet and make the appropriate change(s), if required.

1 Like