Raid 10 question

I am trying to create a RAID10 pool with 6 drives. 4 - 1TB and 2 - 250GB. No matter what I do, the pool gets created as a single (or at least the GUI says single). How do I create a RIAD10 pool? What am I doing wrong? Please advise. Thanks in advance

@asapkota You can only create a raid set with Identical drives, so you could make a raid 1 with the 2x 250Gb and raid 10 with the 4 x 1TB, hope this helps.

Happy Rocking.

I tried that with the 4 1TB drives and still only single. Do the manufacturers have to be the same as well or only the size?

They all show up as 931.50GBs

Is there a way to check RAID level outside on the GUI?

@asapkota @TheRavenKing Are yes! There is currently a couple of bugs that relate to your current experience.
creating a raid1pool makes a single pool but in your case raid10 is also ending up looking like a single. I have added your findings to this outstanding issue. In the issue there is a work around for the time being though.

But unfortunately to see the state of the pool and to apply the workaround I believe you may also run into recently opened #issue752.
So not looking that smooth for you right now I’m afraid.

Also, and you may not like this, Raid levels above 1 are still not generally mature in btrfs at the moment, there are a couple of informative discussions on this matter in this forum over at:-

and another concerning raid levels beyond 5/6 in btrfs:-

@TheRavenKing apparently it is possible for btrfs to create raid1 for example on drives of dissimilar size, there is going to be wastage though but interesting to know that it can; see this github #issue509 for some background on this.

But all these matters have now been highlighted so hopefully things will be a little smoother / more functional very soon.

@phillxnet @asapkota , just wonder, if you would go on the hardware level, assuming you have a raid controller, and you make it a JBOD? [Just A Bunch of Drives] That might work, worth a try?
If not a hardware raid controller check the BIOS sometimes they give a software raid, which is neither a good plan as Rockstor will create the software raid on top of that. That’s asking for trouble.

@asapkota could you provide a little more information of your hardware, Motherboard, raid controller?

It is an old PC that I had lying around. I have been using FreeNAS for years with ZFS.

I think the mobo is Abit K9n Ultra. I am using 6 onboard Sata and 2 more using a PCIe Sata card.

1 x 32GB SSD for the OS
4 x 1TB drives
3 x 250GB drives


BIOS and SATA card do not have option to set RAID mode. Thanks

@asapkota ok, give me some time to work and try out something, because I have only Hardware Raid controllers I will try to do something with Virtualbox for testing.

Is there a way to use CLI to create the pools? Something like mkfs.btrfs -m raid10 -d raid10 /dev/sdb /dev/sdc /dev/sdd /dev/sde

@asapkota Right, let me know how many pools you want and a tell a little bit of your new purpose [usage] perhaps we can do it in a different way.

2 pools

raid 10 with sdb. sdc. sdd and sde

raid 5 with sdf, sdg and sdh


I want something will the same level of data protection as a RAIDZ1 on ZFS. And maximize available storage space. I am open to any suggestions. Thanks

I believe raid1 in btrfs is the equivalent. RAIDZ1 in ZFS can handle the loss of a single drive and total storage is the sum of all disks - 1 disk. btrfs’s raid1 is akin to this, it will store by default 2 copies each on 2 different devices, only you can have as many devices as you like. Nice isn’t it.
from my previously referenced github issue link where similarly sized or otherwise devices in raid1 was covered briefly:-

btrfs reference "RAID-1 is defined currently as "2 copies of all the data on different devices""

Cool. I will try RAID1 then. Lets see if this works.

@asapkota, @phillxnet ok, up and running with 2 pools as you wanted. pool1 raid 5 with 3x500, raid 10 with 4 x500 [example] During install I only selected the 32ssd drive for the system and started to install. Logged in with v3.80-03. all fine so far. Now the tricky bit comes when we do the update AFTER creating the pools, it wrecks the title, perhaps a cosmetic issue? Not sure, but try it yourself and convince yourself that it works with 3.8.0 iso and NO UPDATE!

Regards your last remark about protection, if you allow me to suggest, use the 3 x250 in raid 1, then use raid 6 for the 4 1TB, the problem with huge disks is the time to recover from disaster and the possible break down of more disk in the rebuild. Please don’t forget we are still talking about a Software raid, means a lot of cPU intensive calculations just my thoughts.

1 Like

Same issue.

Regardless of what raid configuration I use on the GUI, I end up with the single configuration.

Did you do this from the GUI? No matter what raid config I try, I always end up with a single config.

@asapkota Yip, perhaps you should give your drives a ZEROWIPE, to make sure nothing left on it from previous raid configs. I always advise to use DBAN zerofill with verify on after each write, it takes a while, but with benefit, you know your disks are fine before using again for a long time!!!

@TheRavenKing If this is a mission critical configuration I think we should be careful recommending raid5 in btrfs as per my previous references. I don’t think it’s considered fully matured just yet.