Rock-ons can't be enabled [SOLVED], Lost access to shares & data [SOLVED], running Rockstor 3.8.16-1


Here are two links to a Dropbox folder that contains the “rockstor.log” file from /opt/rockstor/var/log/

…and the file from /opt/rockstor/

Thanks @glenngould, code not required, but rockstor.log helps :slight_smile:

Asking @phillxnet “Disks Master” too to join this game:

Roland’s rockstor.log confirms my suspicions about boostrap command and shares/pools state refresh (mounting usb??):

[20/Jan/2017 14:14:27] ERROR [storageadmin.middleware:32] Exception occured while processing a request. Path: /api/commands/refresh-share-state method: POST
[20/Jan/2017 14:14:27] ERROR [storageadmin.middleware:33] Failed to mount Pool(usb_hik) due to an unknown reason.
Traceback (most recent call last):
  File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/core/handlers/", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/views/decorators/", line 58, in wrapped_view
    return view_func(*args, **kwargs)
  File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/views/generic/", line 71, in view
    return self.dispatch(request, *args, **kwargs)
  File "/opt/rockstor/eggs/djangorestframework-3.1.1-py2.7.egg/rest_framework/", line 452, in dispatch
    response = self.handle_exception(exc)
  File "/opt/rockstor/eggs/djangorestframework-3.1.1-py2.7.egg/rest_framework/", line 449, in dispatch
    response = handler(request, *args, **kwargs)
  File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/utils/", line 145, in inner
    return func(*args, **kwargs)
  File "/opt/rockstor/src/rockstor/storageadmin/views/", line 262, in post
    import_shares(p, request)
  File "/opt/rockstor/src/rockstor/storageadmin/views/", line 74, in import_shares
    shares_d = shares_info(pool)
  File "/opt/rockstor/src/rockstor/fs/", line 392, in shares_info
    mnt_pt = mount_root(pool)
  File "/opt/rockstor/src/rockstor/fs/", line 264, in mount_root
Exception: Failed to mount Pool(usb_hik) due to an unknown reason.

@Flyer This looks more like a failure during a pool import ( and it’s consequent share import which originates in the low level shares_info which first tries to recover / ensure the mount point of the share via mount_root (root / mnt point of share that is (rename pending)).

So source exception in above is from attempting to mount / retrieve mount point for the usb_hik pool.

That exception is a catch all, not a no disks to try and no logging of having tried any other disks or having got to that stage as it first tries to mount by label.

My guess is that the mount by label failed and we need to catch why (at least for this bit).

The output from the following command (run as root) might help:

mount /dev/disk/by-label/usb_hik /mnt2/usb_hik

(assuming no special mount options are in play for that pool.

But that may be a red herring for this issue but would be good to resolve for log noise removal if nothing else.

Plus when in doubt then more info can help.

Also of potential relevance is the following issue re btrfs mounting by label issue:

Hope that helps.

@Flyer and @phillxnet

Let me clarify quickly the USB drive…this one is not used anymore, the purpose was to get a specific drive mounted which can only be accessed by my HikVision Camera.
-> this one can be deleted

I tried already to do so via the UI without success.

[root@rockstor ~]# mount /dev/disk/by-label/usb_hik /mnt2/usb_hik
mount: special device /dev/disk/by-label/usb_hik does not exist

The USB stick is not connected - unplugged! Should I plug it in again - does it solve the problem? can I delete the pool then?


Our good Rockstor had a “ghost” info about that usb (detached), so trying mounting this on boot makes it fail.

To solve it: plug your usb, reboot, unplug it, rescan disks on WebUI, reboot again

@phillxnet do you agree on this? Anyway, I was surprised about that dev by label instead dev id ?!?

@Flyer Looks good now

Bootstrap is no ON and also Rock-on is ON :slight_smile:

But how I can delete this stupid USB drive that caused all the problems?

1 Like


delete pools under that disk so Rockstor won’t ask them again, detach usb disk, rescan and try a fresh reboot :slight_smile:

@Flyer It should be enough to simply delete the “usb_hik” pool as you stated:

No pool so no background attempt to mount it.

And remember that when deleting detached devices (if that is desired) ie with names beginning with “detached-” it is often required that a recent “Rescan” has been done (bug) ie:

Glad this is looking better now.


@exelan, @phillxnet and @Flyer

Thank you all for your support and sorry for any inconvenience created.:+1:

Problem solved / lessons learned:
Never remove a USB stick before deleting any related pools.
This created problems with bootstrap after reboot and in a second step problems to enable Rock-ons.