Rock-ons issues

i have some issues i was hoping i could get some help with

when i try to ad new rock-ons they fail and the only bit of information i can find about it in the log is this:

[14/Jun/2017 20:18:36] ERROR [storageadmin.views.rockon:81] Rockon(HTTP to HTTPS redirect) is in pending state but there is no pending or failed task for it.
[14/Jun/2017 20:18:36] ERROR [storageadmin.views.rockon:81] Rockon(HTTP to HTTPS redirect) is in pending state but there is no pending or failed task for it.

when i try to turn on or off an already installed rock-on nothing happens and i can’t find anything in the log.

i have tried rebooting but with no effect (all the installed active rock-ons starts up just fine)

i’m currently running version: 3.9.0-9

Updated to 3.9.0-10 today and the issue persists. (i have rebooted since install)

i found that trying to uninstall will give a entry in the log as the one i see from trying to install.

and i have tried keeping an eye on every log i have been able to find without finding anything.

is there any way to check if the services that are needed are running or something else i could do to try to find the root of this issue?


I get the same is in pending state but there is no pending or failed task for it. on three rock-ons I’ve tried to install. Did you manage to get around this?

Hi @maclm,

This error indicates a rather complex state in which a previous task for the rock-on (usually its installation) was pending, but somehow “vanished” without throwing an error that Rockstor could catch. It’s a rather tricky one to reproduce and thus better deal with it, but there are plans for big improvements in the future in this domain.

Now, to get you back on track, I would start by resetting the database information related to these rock-ons. We have an as-yet undocumented script to do just that:

Based on your Github post, you seem to have this issue with three different rock-ons, so you would need to run it for each as follows:

 /opt/rockstor/bin/delete-rockon Syncthing
 /opt/rockstor/bin/delete-rockon OpenVPN
 /opt/rockstor/bin/delete-rockon Ghost

Then, go to Rockstor’s Rock-ons page, and click on the “Update” button in the top right corner. This will refresh the database information for all rock-ons, and thus reset them (more info on what this update does here, if interested).

You should now be able to try again installing these rock-ons.

On a side note, I’m a little concerned as to why you had this issue with 3 rock-ons, as this might indicate the presence of a bigger problem. I thus have a few questions:

  1. Does that mean you are seeing this with all the rock-ons you’ve tried to install?
  2. Is this a new Rockstor install and you thus haven’t had rock-ons running previoulsy, or have you been running rock-on(s) in the past (and still currently) but only now experiencing this problem?

Regardless of your answer to these two questions, I would recommend you to clean-up the relevant database information by running the three delete-rockon command listed above and clicking the “update” button on the Rock-ons page. Then, we can try installing them again and see what happens.

Hope this helps,

Hi @Flox,

thanks for following up on this so promptly :slight_smile:
As I had found the delete-rockon command referenced here, Duplicati installation failed, I of course already tried it. To no avail though.

To answer your questions :

  1. I just tried installing Bitwarden-rs (with no intention of using it, just to try something) and it worked!
    So I tried installing Ghost again, and it worked!
    Feeling lucky, I went ahead and tried installing OpenVPN and it worked!

  2. It’s an installation that is about two years old. I’ve been using Resilio Sync rock-on with great success for a long while now.

I can’t tell you what happened overnight, but it seems to work with everything now :smiley:

This is such a relief as I was envisioning starting from fresh. I mean, I will eventually start from fresh, but I’d like to wait for the OpenSUSE rebase to be available before pulling that trigger.

Maybe it’s worth adding here that I’m still running on 3.9.1-16 as I haven’t figured out how to install updates manually.

1 Like

Glad to read you’re all set now!

Yeah I’m in the exact same situation as you. The new release will be the perfect opportunity to start anew.