Rockstor 4 Installation Freezes on Microserver G7 (N54L)

New member here. I’m not a Linux expert so bear with me. For info, I want to run the Rockstor OS directly from a USB drive on a Microserver Gen7 (N54L).
I was successful in creating a new Leap 15.2_x64 installation .iso file following the “Based on openSUSE” recipe.
I was able to install the OS on another USB drive from an old laptop I have so I know the installer works. That was in UEFI mode.

But running the installer on the N54L fails every time.
Tried regular install several times and it always freezes around operation [20.xxxxxx] (it varies).
Here are some examples of the last line being displayed before it freezes:
“Stopped target Switch root.”
“Started Dispatch Password Requests to console Directory Watch.”
“Mounting POSIX Message Queue File System…”
“Set up automount Arbitrary Executab■rmats File System Automount Point.”

Also tried in Failsafe Mode. It gets farther down past operation [41.xxxxxx] before it hangs at:
“Adding 2097140k swap on /dev/sda3. Priority:-2 extents:1 across:2097140k FS”
It looks like it gets stuck right after creating the swap partition.

The installer never gets to the System Locale selection screen. Could it be a video driver issue?
The BIOS on the N54L seems to run only in Legacy mode. Can that be a problem with the current installer that seems to be made to run in UEFI mode only?

I think I read somewhere that a lot of Rockstor developers own a G7 so maybe somebody can chime in and help me out?
I’m sure there’s a possible fix to my problem. Maybe going with an older kernel with Leap 15.1 instead?
I would really appreciate a push in the right direction.
Thanks in advance!

@petrob Welcome to the Rockstor community.

Well done.

Quite possibly. Take a look at @twermann recent thread/post here here:

where the following may help:

This relates to a Gen10 HP Microserver but may help in your case.


The current installer will install just fine to a bios boot mode system is that is how the installer was booted. But it will install in UEFI mode if it was booted in that mode. That is my understanding anyway. We use the kiwi-ng system to create our installer.

I’m about to embark on creating a Leap 15.3 profile for our installer so hopefully that will be a more forward looking option. But althought I hope to get this done very soon it’s potentially non trivial with 15.3 only being in beta currently; but I’m hopeful. I’ll report back here once it’s done. Also the Leap 15.1 profile and underlying OS is now deprecated and will be removed shortly as Leap 15.1 is now out of support.

If you could do a legacy boot mode install on another machine, or switch the Gen7 N54L to UEFI, then you can always just move the successfully installed Rockstor 4 USB system disk over to the Gen7 and boot from that. You will end up with the donor install hardware Appliance ID but it’s a start.

Hope that helps.

Thank you, Philip for the pointers but for the life of me, I couldn’t install Rockstor via the Kiwi-created image.
Strange since I was able to install Leap 15.2 Server without any problems using the network image on the openSUSE site.
So I went the “hard” way, installing a Rockstor rpm package on top of my working openSUSE Server, following the steps given here:
and here:
This was actually not hard at all. Much easier than going the “recommended” way.
Now I got a running Rockstor server. Woohoo!
Next step, going through Docker to install Jellyfin!


Thank you! I tried to upgrade but I never got a login command prompt. I tried different disks, different boot images (DVD, SD card) - it just would stop at various places. I was looking for fixes for months.
I just added “nomodeset” and it works.

Now I can do other things to break it. Thanks again.