Rockstor fails to boot with kernel 3.18.1

OK, this seems not to be hardware related.
The backplane is also not the problem. I had connected the harddrives directly to the mainboard and now it also happened.

Here are two “Screenshots”.
The fist shows where the system hangs.

After some minutes there are some more messages:

Now this happens on 4 different systems. So this seems to be a software issue.
I can not find a single real hardware, where Rockstor boots reliably.
Only in VMs there does not seem to be a problem.

Many users maybe do not notice this problem, because storage servers are not rebooted this often.

EDIT: One more info:
I have today also tried without any data harddrive connected. Only the system drive was connected. It hangs on boot also in this case.

This is on KVM? did you try acpi=off and it also looks like ecc isn’t on (not sure that’s an issue for rockstor but it is for other NAS distros).

It looks like there is a sound card error, could you remove the sound card or disable in BIOS and see if that improves? (do you need that sound card?) If it’s a VM you should be able to disable it on the VM.

What hypervisor are you using? What are the VM settings for Storage Driver, memory and BIOS?

1 Like

As written above, this occurs on three different machines. So no VMs.

I also have one Rockstor installation in a KVM VM and this is the only one, that does not have this problem.

I already tried disabling soundcard and all other unneeded things (serial and parallel ports and so). This does not change anything.

ECC is disabled because this system does not have ECC RAM installed. So nothing to enable. Also there is no Bios option for ECC.

I have this same issue just today on the latest update of rockstor, 1x 64GB SSD as boot drive. 10x 500MB configured as 1 for storage. Its just a test / play unit at work so not really any use for it right now.
I will leave it for the day and see if it “heals” itself as Suman said up there somewhere, its btfrs fixing the drives?
If not i will scrap it tomorrow and reinstall the OS :slight_smile:


Did you read this Thead?

I have postet a solution there with modifying the nfs-config.service.
Could you try this?

Try if you system boots with network cable disconnected. This helped for me. After I was able to modify the nfs-config.service


@Schrauber Thanks, can confirm disabling nfs resolved the problem for me.

After disabling quit boot I could see that it got stuck at:
Starting nfsv4 id-name mapper

I boot to rescue mode, remounted /root in rw mode and disabled nfs service with

mount -o remount,rw /
systemctl disable nfs

Maybe I’m a bit late, but I hope it helps others.



thanks for the info.

Did you try booting with network cable disconnected? Did it hang anyway?

Completely disabling nfs is maybe not the ideal solution.
Did modifying nfs-config.service not work in your case?
This was my suggestion in the other thread.


I tried booting without network cable, but it got stuck too.
But you are right instead of dialing nfs completely, I could remoint /root
and modify nfs-config.service to start after network is up. Which I did later.

Now it works for me with nfs enabled.