S.M.A.R.T error global name 'smart' is not defined

Hello. I get the error message “global name ‘smart’ is not defined” when i try to run a smart test from the webgui. I get the same error everytime, and i have tried it on all of my 3 disks, resulting in the same error.

I have tried to restart smartd service, and tried to reboot the server but none of it works. I can however run smart tests on my disks from command line via ssh, but not from the webgui. Any ideas?


@mrblomblom Welcome to the Rockstor community and thanks for reporting this. I have confirmed this on a fresh install of 3.8-10 with no updates and a fully updated 3.8-10.02 testing channel and have created an issue to address it. Thanks again for reporting this one.

@mrblomblom I have submitted a pull request with what I believe is a viable fix which worked for me, this will of course have to be reviewed by at least @suman but if you wish to test my proposed fix for yourself then you are welcome to apply the changes detailed in the following link https://github.com/rockstor/rockstor-core/pull/1061/files
You can edit (via nano) your rockstor’s /opt/rockstor/src/rockstor/storageadmin/views/disk_smart.py installed file with the changes indicated in the above link and then restart your Rockstor system to enable the changes. Be careful not to change anything else and if in any doubt then disregard these rather brief instructions.

If this patch passes review then it should be available in the next Rockstor testing channel update after that and subsequently in the following stable channel update.

Let us know how you get on. No worries if you don’t fancy the editing / testing and thanks again for reporting this issue.

@phillxnet Thank you for your answer. I replaced the lines according to your instructions, and now it works! I have now completed 2 short self tests from the gui on 2 of my disks, and sucessfully started an extendet test which is not yet completed. The error message is gone, and everything seems to be in order. This fix/patch or what the correct word would be worked for me. Thank you!

@mrblomblom That’s great and thanks for verifying it. Glad it worked and thanks for reporting back again.

@mrblomblom Just to let you know that this fix/patch has now been incorporated into the latest release of the testing channel updates version 3.8-10.03. Thanks for you help on this one. Dev log for upcoming 3.8-11.