Samba Service broken after update -11


Great, glad to hear it; and thanks for the confirmation / testing.


Not as far as I’m aware, at least in the issue record anyway.

@doenietzomoeilijk Would you care to make a GitHub issue with this feature as a request and indicate @Flox as a second suggester. Might be nice to link back to this forum thread also as then the implementer can see the genesis of the request as it were. Not entirely sure how we would monitor such a thing but as mentioned we could reflect a yum db lock status as a warning that package maintenance is ‘currently active’ or the like with a suitable warning against ill advised actions or the like.

Nice work people (@Bert, @Haioken, @doenietzomoeilijk, @Flox)

No problem, I’ll cook up an issue tomorrow morning - it’s getting kinda late here, at the moment. :wink:

There’s an issue up - @Flox, feel free to +1 it.

I was having the same issue after installing 3.9.1 on a new machine and I had tried installing all the updates including the most recent test channel updates and it sill wasn’t working until I found this thread. I tried each recommendation one at a time and nothing worked (including systemctl restart nmb.service at first), and yum wouldn’t let me reinstall libwbclient-4.6.2, so I uninstalled it (only, I left the dependencies since there were many) and then installed it again, and while I was at it I ran yum clean all and then eventually something clicked and systemctl restart nmb.service finally fixed it.

After writing all that I see that I seem to have had the same issue as doenietzomoeilijk, with the SAMBA_4.4.4 not found popping up somewhere along the way. And now that I’ve read through and saw that it may have been caused by an interrupted update cycle, I may have rebooted during an update as well. I was booting off a really slow USB flash drive and it wouldn’t shut down, so I thought it had some issue and just turned the computer off after a few minutes and restarted, so that may have been what caused my issue as well, maybe?

1 Like