Update PLEX .... a long running problem

It’s been a while with plex - update it: within docker image, or try to find newer image … or … ?? suggestions ?

I’ve done an update yesterday as the Plex UI was telling me there is a newer version, so I stopped Plex and pressed the Update button from Rockons (upper right corner) and started again Plex-done :grinning:


WHAT ??? I thought that this button was to only update the list of rocksons if you have a stalled link or something went wrong with startup / shutdown … I would never consider this button to actually download newer version of docker image !!!

( still being gob smacked :smiley: )

You don’t even need to hit the update in the Rock-Ons page (yes, it only updates the list).

The Plex docker image does on update on start; restarting the RockOn is enough to get it to update.

okay, I’ve never tried it with only turning Rock-ons on/off within hitting the update button :sweat_smile:

Anyhow, it would be good to indicate anywhere (pop-up, red text) that an update is available and you should restart Rock-ons. Or to showing the version number for each installed and available Rock-ons program…I’ve asked for such a feature back in January

After some investigation by @Flyer I think it has been parked for now due to difficulties.

Well this never worked for me …

@Tomasz_Kusmierz Hello again.

I’m fairly sure this auto update is dependant on having your Plex server rockon registered, ie via a Plex user account. That way the startup update scripts in the container can validate the version of the software appropriate to your account, ie if your Plex account has a Plex pass associated with it or not. It can then check and download the appropriate version. Otherwise it sits at whatever the default version was when first installed.

Also from:
we have:

"Note about updates, if there is no value set for the VERSION variable, then no updates will take place.

For new users, no updates will take place on the first run of the container as there is no preferences file to read your token from, to update restart the Docker container after logging in through the webui


latest: will update plex to the latest version available that you are entitled to.
public: will update plexpass users to the latest public version, useful for plexpass users that don’t want to be on the bleeding edge but still want the latest public updates.
specific-version: will select a specific version (eg of plex to install, note you cannot use this to access plexpass versions if you do not have plexpass."

(minor formatting edit required around “specific-version” within quoted text)

Hope that helps.

So I’ve got plex pass and my setting was set to latest … still it was telling me I have to update manually … so I did:
docker exec -it 439785293875 bash
wget link_to_deb_package
apt-get deb_package

ps. It was telling me to update for few months …

Just FYI:

I don’t think latests is a valid variable for version. Try latest as per the docker docco.
You shouldn’t lose anything if you map all the shares up in the same way after an uninstall/install.

1 Like


so I think we’ve found a problem - default option is latestS

@wraeuk Well spotted, and welcome to the Rockstor community.

Just checked our Rock-on description offered for the “Version”, just in case, and it looks to be OK:

although we have a little matter of a missing Capital and full stop by the looks of it. (Pull Request anyone).

and the Docs Plex Server Rock-on look to be OK too:

VERSION ie latest for latest version or a specific version if desired.


@Tomasz_Kusmierz There is no default option; however upon re-install the previous contents for a field can be re-asserted, I had previously put this down to a browser caching thing. Oh well looks like we are there finally.

It’s good to have gotten to the bottom of this one as it was a little perplexing.

@phillxnet so unless there is no default (and never was) and the tool tip is good (and always was) safest to assume that I was high os something to put S at the end. Would it be better to add default ?