Updated to newest Rockstor now getting Samba Error

I did an update to the newest Rockstor (3.9.2-44) and upon reboot I am unable to start my previous Samba share. Can’t remove it to maybe re-add the share (get error on that too). The error upon trying to start Samab service follows:

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/smart_manager/views/samba_service.py”, line 113, in post
systemctl(‘nmb’, command)
File “/opt/rockstor/src/rockstor/system/services.py”, line 64, in systemctl
return run_command([SYSTEMCTL_BIN, switch, service_name])
File “/opt/rockstor/src/rockstor/system/osi.py”, line 121, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/bin/systemctl start nmb. rc = 1. stdout = [’’]. stderr = [‘Job for nmb.service failed because the control process exited with error code. See “systemctl status nmb.service” and “journalctl -xe” for details.’, ‘’]

Any thoughts on how to correct this issue so I can get to my data?  Thanks.

Before update all was working fine.

Hi @Darevsek,

Sorry to read you’re having issues with your Samba shares. It’s not the first time that I see Samba misbehaving after updates… but would you be able to provide the output of the command listed in the error message?

journalctl -xe


systemctl status -l nmb.service

These may facilitate identifying the issue and accelerate the solution.


Thanks for the reply. Here is the output of those comands.

journalctl -xe:

Hint: You are currently not seeing messages from other users and the system.
Users in the ‘systemd-journal’ group can see all messages. Pass -q to
turn off this notice.
No journal files were opened due to insufficient permissions.

Sorry, bit of a Linux newbie so not sure how to get the Journalctl part from webUI shell. Tried the Sudo but got “is not in the sudoers file”. how do I get the this part?

systemctl status -l nmb.service:

● nmb.service - Samba NMB Daemon
Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabl
Active: failed (Result: exit-code) since Thu 2018-12-06 12:24:28 PST; 17h ago
Docs: man:nmbd(8)
Process: 16296 ExecStart=/usr/sbin/nmbd --foreground --no-process-group $NMBDOPTIONS
(code=exited, status=127)
Main PID: 16296 (code=exited, status=127)

Looks like you are not logged in as the root user.


You could also try, for convenience, System - Services - Shell In A Box (spanner icon)

It’s less secure but it then allows you to login directly as root ie:


and then we have:

Hopefully that should help with getting root access to continue diagnosing as per @Flox’s suggestions.

Thank you for the info. I changed the setting from Login to SSH like you have but when I put in root and hit enter it just sat there and did nothing. I then loaded up Putty and was able to get the info.

journalctl -xe

– The start-up result is done.
Dec 07 09:37:42 rockstor sshd[11918]: pam_unix(sshd:session): session opened for
Dec 07 09:38:43 rockstor systemd[1]: Reloading.
Dec 07 09:38:43 rockstor systemd[1]: Reloading.
Dec 07 09:38:43 rockstor systemd[1]: Starting Samba NMB Daemon…
– Subject: Unit nmb.service has begun start-up
– Defined-By: systemd
– Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

– Unit nmb.service has begun starting up.
Dec 07 09:38:43 rockstor nmbd[12388]: /usr/sbin/nmbd: error while loading shared
Dec 07 09:38:43 rockstor systemd[1]: nmb.service: main process exited, code=exit
Dec 07 09:38:43 rockstor systemd[1]: Failed to start Samba NMB Daemon.
– Subject: Unit nmb.service has failed
– Defined-By: systemd
– Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

– Unit nmb.service has failed.

– The result is failed.
Dec 07 09:38:43 rockstor systemd[1]: Unit nmb.service entered failed state.
Dec 07 09:38:43 rockstor systemd[1]: nmb.service failed.

@Darevsek Given that since our iso was last released, our base linux distrobution (CentOS currently) had a major update and in some cases this caused an issue that may be what you have experienced here. Linking to a thread that dealt with a few cases of this:

It may not be the same thing but it’s worth a read and may help others help you further, or just help to rule that cause out.

Sorry I can’t chip in more right now so just thought I’d leave that link as I just found it.

1 Like

phillxnet - Thanks for the link.

yum reinstall libwbclient -y


systemctl restart nmb.service

worked. Samba is back up and running again. Hopefully will be stable here on out for a bit. So Solved for now. Thanks all.

@Darevsek Glad your sorted and thanks for the update.

It would also be a good idea I think to make sure that all is still well after a reboot as then you can be more assured that you are on solid ground as it were. Only caveat is to try not to interrupt a software update with a reboot as this can cause all sorts of issues. We have a little weakness on that one and have the following issue for this opened by forum member @doenietzomoeilijk :

Although we have some degree of yum activity via the tool tip of our fan icon system update initiated in the Web-UI header (it updates all but the rockstor package). Although I think this could do with being more prominent as per the issue.