Veille des disque dur

Bonjour a tous voila j’ai une question peut on réglé via l’interface web la veille des disque dur car je n’ai pas trouvé et j’ai l’impression que mon disque tourne en continue 24h/24 ce qui me fait peur quand a ça durée de vie , Merci d’avance .

:flag_fr: Bonjour a toi @phil47 et bienvenue dans Rockstor! :flag_fr:

Ok, my french talking/writing stops here so we’ll go on english :wink:

Reading your message I understand you’re asking about disks spinning 24/24h and a way to avoid this via Rockstor WebUI: actually Rockstor has a good disk management letting you to spin down disks too, thanks to Sir @phillxnet :flag_gb:

@phil47 Bonjour, s’il vous plaît voir la colonne d’état de puissance de la page de disque. Là vous avez un sablier. Excuse mon traducteur français google.
Je un m apprends le français mais très tôt journees

Grâce à monsieur @Flyer pour la mention.

Nous n’avons pas encore documenté cette caractéristique.

Le manual officiels du Rockstor.

J’ai ouvert un ticket pour le faire:

1 Like

hello and thank you very much to everybody i have done what you said phillxnet and i’ve made it i set it to 10 minutes , now it’s just perfect . Just if that can help someone my nas is made with an asrock n3050 board with new intel proc , and with the new rockstor 3.8.15 the installation is good but when i reebot the nas can not connect to the ethernet , but with the rochstor 3.8.14 everything is good , i think it has something to do with the linux kernel because i’ve tried openmediavault 2.1 and it has exacly the same issue has the new 3.8.15 .

1 Like

@phil47 Thanks for the report and glad you got the disk power thing sorted.

Have you tried the latest testing channel updates on 3.8.15 as this comes with a newer kernel version 4.8.7 that may help with the network problem. This same kernel is likely to be used in the soon to be next stable release of Rockstor.

Please report back on if testing channel updates on 3.8.15 plus reboot into newer kernel helps with network. Or if this new kernel is the problem.

Merci d’avoir signalé ceci.

Hi @phil47,
can you please confirm info about your nic? is it on Realtek RTL8111 family?

EDIT: is it on that family or an lsmod | grep r8169 from shell has that driver?

1 Like

hello , sorry i do not whant to risc to test because i am going to retransfert all my data to my nas and it’s going to be very long , i have install the 3.8.14 , my computer gona work all the night for 3 or 4 days . but thank you very much for all your help .

hello , my lan chip is RLT 8111GR , and the problem is when the nas reebot after the install i type the ip 192.168.1… on chromium on my pc and he give me an error , so i go to the web interface of my box and to the lan set up it saind that the lan is connected to gigabit but not connected and no ip is atribued this only with the 3.8.15 of rockstor , with the 3.8.14 of rockstor there is not this problem , so i have installed the 3.8.14 .

1 Like

Good @phil47, wait, not good at all, but at least you confirmed my mind! :slight_smile:

Realtek Cards usually run on linux with r8169 driver and it’s a well know not working one, so your solution is to move to Realtek r8168 driver.

Having some checks via google you’ll find detailed how-to doing this on centos distributions.
If you need help ask here :slight_smile:

1 Like

@phil47 and @Flyer By way of a test here I’ve just updated to 3.8.15-9 testing channel on an ASRock N3700-ITX motherboard.

I agree with @Flyer to leave for time being given you are busy populating data drives.

The kernel version on my ASRock is now:

uname -a
Linux cube 4.8.7-1.el7.elrepo.x86_64 #1 SMP Thu Nov 10 20:47:24 EST 2016 x86_64 x86_64 x86_64 GNU/Linux

and the Ethernet controller is:

lspci | grep Ethernet
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)

The install is bios based not UEFI.

lsmod | grep r8169
r8169                  81920  0 
mii                    16384  1 r8169

All appears to be OK currently.

From my desktop:

 iperf -c cube.lan
Client connecting to cube.lan, TCP port 5001
TCP window size: 85.0 KByte (default)
[  3] local port 49316 connected with port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.10 GBytes   941 Mbits/sec

with the following command running on the rockstor machine “cube.lan”:

iperf -s

‘Ctrl + c’ to cancel the running iperf -s on the Rockstor.

Adding details here by way of test on similar hardware.

hello , ok i well wait for the next stable 3.8.16 for update , thanks very much for your help .

@phil47 Hello again, just an update on the issue that was opened as a result of your initial post:

The issue has now been closed and we now have a new HowTo in the docs: Disk Power Down which is linked to from our also updated Disks page.

Thanks again for bringing attention to this ‘omission’ in our docs.