WD drives showing as unknown

So i have 2 WD drives, model numbers WDC_WD80EZZX-11CSGA0 i was able to get them working and added to the pool and everything however they continually show up as greyed out and unknown in the disk list. They appear to be active and working and data seems to be read and written to them but them showing up as unknown is concerning.

I am running a LSI 9211-8i in IR - running the latest firmware and BIOS.

Running the latest stable release 3.9.2-31

I’ve tried the megaraid argument in the SMART settings but either my card doesn’t need them or the commands are not supported, because when I enter them SMART then shows as unsupported for the drive.

Without the custom options at least smart shows up and I can run quick and extended tests, when the tests are running the drives show up as active in the disk list.

@cferra Welcome to the Rockstor community, and thanks for helping to support Rockstor development via a stable subscription.

I’m assuming here you are referring to the drives “Power Status” column entry. It’s the only “unknown” Web-UI column entry on the Disks page that comes to mind, ie:


If so this is simply a default state if a certain hdparm command returns an error or a result which is not ‘understood’. The code in question is the following:

Clicking on the “show original” will give the entire rather short code snippet that deals with the “Power State” column entry text.

This is not really a concern as it just means the output of the following command, as executed with your drives by-id name, was interpreted as ‘unknown’:

hdparm -C -q device-by-id-name-with-path

An example for a virtio drive with serial = “serial-6”:

hdparm -C -q /dev/disk/by-id/virtio-serial-6 
 drive state is:  unknown

It would also be helpful to see what the return code was from that command: ie directly after executing the hdparm command if you could then execute the following command:

echo $?

We see here that a return code of 25 was recorded from the hdparm command on a virtio device. The indicated source code classes any error output “len(err) !=1” as an unknown state, this error text is normally part of the command output if I remember correctly.

We may have an opportunity to improve this columns scope here (ie for your drives through LSI controller ‘unknown’ issue); or it may just be that hdparm can’t handle this scenario. We do have a related issue open for the scenario where we also use hdparm which is known not to be able to set drive power down settings (the related use of hdparm) when the drive is behind a raid controller:


Your drives by-id names can be listed via:

ls -la /dev/disk/by-id/

and are the names displayed in the Name column of the Disks page, remember to supply the path.

This is a currently not a directly related issue, ie hdparm is used for the Power Status and APM columns where as smartctl is used to establish if we can gain smart info for use in the pages that appear when you click on a drives names: as shown in our S.M.A.R.T doc section. If the smart column doesn’t show as “Not supported” and the smart pages show up ok then it would seem you don’t need custom smart options.

We have had a recent improvement on drive name validation which may affect your chosen custom smart options; see issue:
which has been initially addressed by pull request:


which was merged as part of Rockstor version 3.9.2-30 so fairly recently.

Looks like this may have impact on our parsing of LSI dev names also. The original forum member reporter of the megaraid dev parsing issue, @coreybrett, has yet to confirm the effectiveness or otherwise of these recent changes to the dev name parsing in our custom smart options re the megaraid option:

Hope that helps and lets see what your hdparm command is returning for those unknown / active drives, ie you could test the hdparm command for the drives while they are either unknown or active (if I have understood your description correctly).

So I got this result - not sure if I ran it correctly –

hdparm -C -q /dev/disk/by-id/ata-WDC_80EZZX-11CSGA0_VLJHLE1Y
drive state is: unknown

echo $?

here is a copy of what my disk UI shows.

@cferra Thanks for the feedback and command output.

OK, so that is where the ‘unknown’ status is coming from. Essentially harmless.

It would appear that hdparm for these disks, at least how you currently have them connected (behind the LSI presumably), just can’t tell us their power state (active/idle etc). Nothing much we can do about this but in time the situation may change if this behaviour is improved upstream.

Thanks for the feedback. I wouldn’t worry about this as it’s a ‘nice to have’ Web-UI feedback element only.

Just received you Disks table picture post. At least you were able to set the power down / Spin Down setting:
“Vendor defined (8-12h)”

You could let us know if this feature works as it’s a bit hit and miss with various hardware and you may well be a candidate for the “extend custom smart parameter support” issue I linked earlier. Ie setting this option through raid controllers can be tricky.

This has reminded me that we are due for a technical wiki entry for how this element of Rockstor works. I’ll have a go at that soon but in the mean time the following was the pr that added this feature and contains a run down on how it works:

Hope that helps and I’ll try and get that wiki entry done soon.