3.8.15-0 Dashboard, TopShare Usage, not correct

I think there has been spent already a lot of work to improve the different dashboard widgets, but it seems there are still some bugs…look at the attached screenshot.
My rock-ons-root share has 5GB allocated which is correct but only ~500MB are used, it shows 24,7GB are used which equals close to 500% ?

As far as I know this is actually a problem with btrfs and that quotas are not working as they should as of yet.

When I get these errors I run a “btrfs quota rescan (name_of_pool_where_you_have_your_rockons_setup)”, at the cmd-line and this rectifies the problem for some time.
Until quotas work in btrfs, I think this problem will persist?

Hi @glenngould,
can you please try @KarstenV solution (thanks for suggestion!) : I’m quite sure this is not widgets related


OK - I’ve tried the follwing syntax, but I guess that is not correct -> syntax error
I don’t have any experience with this tool :confused:
“btrfs quota rescan rock-ons-root2” or “btrfs quota rescan (rock-ons-root2)”

@glenngould First off a very belated ‘Welcome to Rockstor’ to you.
As per the command, you will need to specify the subvolume / share by it’s full path:

btrfs quota rescan /mnt2/rock-ons-root2

And hopefully if all is well that should respond with:

quota rescan started

Hope that helps.

Also note that this command must be executed by the root user.

Thanks - it worked out now on the command line - no error.

But the dashboard still shows the same 500% - I’ve not tried to reboot the server if this helps…

Hi, could you provie output of:

btrfs fi show
btrfs fi df /mnt2/rock-ons-root
btrfs fi su /mnt2/rock-ons-root

btrfs fi show

Label: ‘rockstor_rockstor’ uuid: 4b9b3b4f-6697-46fc-a7ca-6fc36e8b3b43
Total devices 1 FS bytes used 2.11GiB
devid 1 size 113.88GiB used 18.02GiB path /dev/sda3

Label: ‘rm_pool’ uuid: d5829eb2-f19f-4329-83a4-c71261a270bf
Total devices 3 FS bytes used 942.60GiB
devid 1 size 3.64TiB used 475.51GiB path /dev/sdb
devid 2 size 3.64TiB used 475.51GiB path /dev/sdc
devid 3 size 3.64TiB used 475.51GiB path /dev/sde

Label: ‘usb_hik’ uuid: 17422e07-4447-4a02-a40a-ed2bf3910e72
Total devices 1 FS bytes used 224.00KiB
devid 1 size 7.50GiB used 276.00MiB path /dev/sdd

btrfs fi df /mnt2/rock-ons-root2

Data, RAID5: total=948.00GiB, used=940.98GiB
System, RAID5: total=16.00MiB, used=96.00KiB
Metadata, RAID5: total=3.00GiB, used=1.62GiB
GlobalReserve, single: total=512.00MiB, used=0.00B

btrfs fi su /mnt2/rock-ons-root

error / “su” is unknown command

that’s a typo
btrfs fi du /mnt2/rock-ons-root

now it worked…couple of thousands lines showed up…here the last one

23.16GiB 467.26MiB 1.91GiB /mnt2/rock-ons-root2

The couple of thousands might actually point us to the problem … ( surely it’s not more than a hundred right ? )

No really, it takes close to a minute…lines are flowing…I can’t capture (copy&paste) all of them from the terminal, as you can scroll back only a few pages

Hahahaha … actually I got it now, I’ve wrote “btrfs fi su” while @Flyer fixed my typo to “btrfs fi du” … while I wanted to see "btrfs fi us"
clasic, sorry mate

@glenngould FYI, I have similar issue, the rockon root storage consumes no space and device utilisation if vertually non existing, yet the display says that is’ using 35 GB … so @Flyer if you need me as a guinea pig as well … you know.