4.2 kernel doesn't work with Asus Chromebox with custom firmware

I ran the system update for 3.8-8 from the WebUI and now Rockstor will not boot. It will still boot off of the older kernels. I have a somewhat odd setup. It is an Asus Chromebox (Celeron processor) with custom firmware, and I have a 4TB WD My Book attached via USB3. Any help you can give is appreciated. Below is what I see when I boot from the latest kernel in debug mode. I know this is not enough to go on, so please let me know what you need to help me figure this out. I haven’t had this happen before.

EDIT: I just updated the firmware to the latest version and still see the same thing at boot.

Sorry to hear that the new kernel doesn’t work for your setup. It’s the risk we take to stay on the cutting edge with BTRFS and I can only test on machines I have here before releasing an update. So, I can’t really help you make the kernel work, but I am positive that others on this forum can provide better guidance.

You may be ok with just using the 4.1 kernel for now.

without going into details this bug seems to be related to interrupts not beeing handled like they should in migration.c inside the assert_raw_spin_locked(&desc->lock); function, so besides checking for some biossettings regarding irq/acpi you cant do much except compiling your own “fixed” kernel. Here is a thread about this bug, might be fixed with the next kernel release from rockstor where this bug might be fixed upstream.


Thanks suman and felixbrucker. So it looks like the only thing I can do is go back to 3.8-7. I tried booting from the older kernel, not everything works. That is to be expected I suppose. I think I will install Rockstor from the .iso unless anyone has a better idea. Thanks again.

Which features are not working with 3.8-8 but with 4.1 kernel?

TimeMachine on my macbook pro couldn’t connect to the share. Could this be caused by something else?

Yes. I don’t see that being related to the kernel version at all.

Are you using AFP or Samba to connect to the Share from your macbook?

afp i believe. I am booting it up again to see if I can get it to work.

Looks like you were right suman. I can connect to Rockstor, just not from the finder. Time Machine is working. Looks like I don’t have to roll back to 3.8-7. I will look more into this tomorrow and see what I can find. Thanks for your help.

1 Like

Could you please update the title with the exact problem description? Perhaps something like “4.2 kernel doesn’t work with Asus Chromebox with custom…”?

Kernel 4.2.5 in the 3.8-10 no longer has this issue.

1 Like