Activation code(JbNgJuWgDZP97PTW5vBRIQ

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

I’ve reinstalled my NAS and tried to activate updates again, I purchased this in 2015, so I’m not sure if it has expired?

Detailed step by step instructions to reproduce the problem

It asked for activating updates I entered my code and it gave this stacktrace:

Web-UI screenshot

[Drag and drop the image here]

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/", line 86, in post stableo = self._toggle_repos(password=password) File "/opt/rockstor/src/rockstor/storageadmin/views/", line 66, in _toggle_repos raise Exception(e_msg) Exception: Activation code(JbNgJuWgDZP97PTW5vBRIQ==) could not be authorized. Verify the code and try again. If the problem persists, contact

@rayburgemeestre Hello again and thank for helping to support Rockstor development.

As you say it may have expired, or your machine’s motherboard may be one of those known to have a non unique ‘fake’ product_uuid, see the following forum thread by @mmmdonuts for some info on this:

Essentially if your appliance id has changed between installs then the activation code will not work. They are a set. And we try to keep appliance id stable between installs, and hence keep the activation code working, by looking at the output from the following command in order to set the appliance id:

cat /sys/class/dmi/id/product_uuid

But don’t post your output as you have already posted your activation code.

So if your product_uuid is either of:

then your issue may well be that your appliance id has not remained the same between installs as if the code finds one of those fake_puuids (see caveat later) then it has no choice but to generate an install specific one which of course will break the activation code upon a re-install.

The caveat:

@mmmdonuts helped to point out that we had a typo in the code with regard to these known fake product_uuid’s and this was then fixed in an update to stable channel via the following issue:
and now merged pull request:

You can open a private message to me if you wish to post your product_uuid, ie if it looks to be one of those or another example of a non unique one (obviously hard wired rather than a random sequence of numbers and letters) and we can add it to the list of known ones. But of course that fix only comes in after upgrading so until we release it in testing or have another iso it’s a chicken and egg problem. But still if you have one of those then their is still a problem.

As the message states, you are going to have to contact with your old and new appliance id (if in fact they have changed) as then it can be transferred. Or to enquire as to if it has, either been subject to this coding bug re the fake_puuids or if it has simply run out. I can’t look that stuff up myself unfortunately.

Hope that helps and if you want to post your current product_uuid do it via a private message to me, I should have a forum Moderator badge (shield) by my name, then I can take a look as well.

Hi Philip,

I’m sorry for not having replied to your message at the time.
I never saw it, but I did get an e-mail, only today when I was looking for my activation code did I find it!

I already replied to you via e-mail just now, just to update here my motherboard (ASRock Rack C2550D4I) was indeed one of those boards that have this fake product_uuid.

Consider this problem solved anyway, I’m happy the way it runs already out of the box for years so :smile: