AFP shares not announcing


I have a fresh install of Rockstor.

My SMB shares work great on OSX (10.12.6) no issues there.

I cannot, however, get AFP to announce or connect correctly or consistently.

There is no firewall enabled on the client.

Trying to connect manually using afp://user@ or some version there of will bring up the user connect message, but will report the share cannot be found. I was able to locate the share once, and have it appear in in the time machine options, but attempting to initiate a backup resulted in an error reporting there is a problem.

Suggestions? Are there known issues with AFP here?

SMB works well, but I need to be able to do time machine backups.

@smanley Welcome to the Rockstor community

Not that I’m aware of (apart from s potential old one referenced below), have you tried enabling the Time Machine element of the APF export?

I don’t have a running AFP share that I can test currently but I’ll try and dig out an old one I used for testing before, but last time I did it was setup as per the following doc Apple Filing Protocol (AFP) section which focuses on setting up for Time machine use as that’s pretty much all AFP is used for it seems these days anyway.

Although we did / may still have, the following issue that seems to have affected pretty much all NAS’s:

It was closed as there was little we could action for it.

Hope that helps.


In case it helps others;

I blew away the install as I’m evaluating and set everything up again. I tried everything.

I set it up so there were only time machine shares on AFP and it appears to be working now.

I had to manually let the OS know about the share using connect to server and the afp://username@ip.x.x.x/ approach. Once this connected Time Machine saw the shares.

1 Like

@smanley Thanks for the update and glad you got it working.

Looks pretty similar to @d549e5 's findings / workaround in that issue.

I think Apple in OSX have now defaulted to showing cifs/smb shares in their last few OS releases with AFP shares being demoted somewhat.

Still it would be nice to keep an eye on this one as I’m pretty sure we could do with some work on our
avahi config. Had a quick look a while back but it needs more time than I had previously put in.

Thanks again for sharing your findings / working config.

Super helpful. I was fumbling around trying to get time machine working and finally set it up in a matter of minutes. Cheers