[ALERT] Dropbox needs to rename your existing folder


I have tried the Dropbox Rockon, I have tried a few other docker images. I have problems setting up dropbox with all of them.

Most of the time I get the error: [ALERT] Dropbox needs to rename your existing folder or file named Dropbox to finish installing. Please close any open documents and try again.
It is getting spammed in the logs.

Has anyone else happened upon the following error, after successfully linking the dropbox account?

What else have I tried?
I have tried using the “admin” and “nobody” UID/GIDs.
I have tried deleting /dbox/Dropbox, but it says “device or resource busy”. lsof +D comes up empty. I have tried unmounting it, but it seems I don´t have enough privileges in the docker image itself.
I have tried various chown and chmod with too many privileges…
I have tried using Maestral (a 3rd party implemention of Dropbox), but it doesn´t respond in CLI mode.
EDIT: I have also tried the SKIP_UPDATE thing.

What have I not tried?
Mounting the data and config shares via bind mount. I don´t know how to do it, but I think it would work, because /dbox/Dropbox comes pre-mounted anyway, so there isn`t much I can do. Or?
Maybe I should add an addition data bind mount, and configure dropbox in the container to use the new mount? I would need some direction here, since I am new to Docker and Rockstor…


Hi @aremiaskfa,

I haven’t tried it myself, but a quick Googling seems to indicate this is an unfortunately common issue, even with other Docker images for Dropbox. Some report having luck using the SKIP_UPDATE variable; given your error does appear to be related to Dropbox updating itself, I wonder if you had tried it.
This would be setting $DBOX_SKIP_UPDATE to True in the Rock-On install wizard.

Also, I noticed that the Docker image we are using is rather old (6 years!). After a quick look at the Dockerfile, though, it appears it simply apt install the dropbox package from the repo. We should still try to find an image replacement, though.


Thank you for your answer.
Yeah, I have tried that as well, but no luck.
EDIT: I still haven’t tried a tagged version though. Will report back.

The Docker image you are using is probably fine.
But otherguy/dropbox seems quite popular and has a few ENV vars more exposed. But that one was also a year ago…

1 Like

I’ve zypper installed Dropbox-CLI on host and it went really smooth. Will test it a little, if Dropbox syncs without a hitch.
This is an acceptable workaround for me.

I’m a Docker beginner, but maybe I should create my own Dropbox image/rockon from opensuse 15.4 and zypper?

1 Like