Announcing Rockstor 3.8-10

Hello Everyone,

I am happy to announce that we just made 3.8-10 available! And I am super happy that it din’t go into the weekend :smile: I want to thank everyone in the community for your contributions of code, testing, r&d and great company!

Those of you following the dev log post know very well that Replication feature got a complete overhaul. The new implementation is pretty robust and I look forward to all of us using it.

As usual, the announcement blog post has more information about the release. Please give it a quick read!

Stable channel subscribers, thanks for your support and patience. Please update from the Web-UI and feel free to e-mail me for support. And to my friends living dangerously with Testing updates, thanks for playing! For new users, I’ve created a new ISO being uploaded as I write this. Download here.

Is -9 rolling out to dev channel then? or we are not getting more updates?

Do you mean Testing channel? If so, you can get the latest 3.8-9.09. There is no “dev” channel.

@suman Is the torrent going to be uploaded anytime soon for this new build? The current torrent file on the download page is for the 3.8-9.02 build.

I’m not using Rockstor yet, but plan to within the next 6 months. In the meantime I want to help out by seeding. I also have no interest in downloading anything from Sourceforge.


Very kind of you to seed. I just updated the link. Thanks for you comment and please seed away!

@baggar11, you may be interested in grabbing the torrent too :smile:

@suman Thanks for the quick upload! Downloading now (well, waiting for peers), and will seed until a new version drops!

Here’s the md5sum of the torrent file, please double check if you have any issues: 2166d2d8759ec4c122dd700a132d50cf

@suman Thanks for the md5sum. The first download was giving me something different, but re-downloaded and now getting the correct sum.

Got 1 peer now, and downloading!

updating to the 3.8-10 version didn’t happen automatically.
the email notification I got was because of a missing key.


warning: /var/cache/yum/x86_64/$releasever/Rockstor-Stable/packages/rockstor-3.8-10.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 08795b09: NOKEY
Public key for rockstor-3.8-10.x86_64.rpm is not installed
Public key for kernel-ml-4.2.5-1.el7.elrepo.x86_64.rpm is not installed
Importing GPG key 0x08795B09:
Userid : "Suman Chakravartula (Rockstor RPM development)"
Fingerprint: 2745 c09d 683c 126b 05e0 99d7 032b 764d 0879 5b09
Package : rockstor-release-3-8.9.el7.x86_64 (@rockstor)
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-Rockstor
The following updates will be applied on Homeserver:

Package Arch Version Repository Size

kernel-ml x86_64 4.2.5-1.el7.elrepo rockstor 37 M
rockstor x86_64 3.8-10 Rockstor-Stable 21 M

Transaction Summary
Install 1 Package
Upgrade 1 Package
Updates failed to install with the following error message:
Didn’t install any keys

I did yum update via SSH which allowed me to accept the key, this is a issue which shouldn’t happen on the stable tree I would say.


I’d like to know a bit more info @herbert. Which version of Rockstor were you running prior to the update? The public key itself was pushed out with -9, IIRC. The message above also indicates that yum is trying to use the key(/etc/pki/rpm-gpg/RPM-GPG-KEY-Rockstor) which is further confusing because that means the key is already there?

Just grabbed the new ISO and will be seeding until the next ISO is out :smile:

btw: Having issues upgrading to the new release on my install. Finally figured out there is something funky going on with the yum side of things. Which I’m not too familiar with. I eventually get the following error mailed to the root account.

–> Finished Dependency Resolution
Error: Package: 4:netatalk-3.1.7-0.1.el7.centos.x86_64 (@anaconda/3)
Removing: tracker-0.16.2-11.el7.x86_64 (@anaconda/3)
Updated By: tracker-1.2.6-3.el7.x86_64 (base)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

The full output of the root email can be seen here.

@baggar11 that’s a transient issue. There was a window of time during which updated netatalk package was not available, triggering this issue. as of this morning Pacific time, the issue is auto resolved.

And as always, thanks for seeding!

Hmm, just ran the update again and got the same email.

From root@rockstor.localdomain Tue Dec 15 11:03:18 2015
Return-Path: root@rockstor.localdomain
X-Original-To: root
Delivered-To: root@rockstor.localdomain
Subject: Output from your job 8
To: root@rockstor.localdomain
Date: Tue, 15 Dec 2015 11:03:18 -0800 (PST)

Error: Package: 4:netatalk-3.1.7-0.1.el7.centos.x86_64 (@anaconda/3)
Removing: tracker-0.16.2-11.el7.x86_64 (@anaconda/3)
Updated By: tracker-1.2.6-3.el7.x86_64 (base)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

So what is my next step for a resolution? RockStor’s updating mechanism doesn’t seem to be fixing itself.

Looks like your yum cache has not expired yet. You can run yum clean metadata and update again, or wait. Let me know how that goes. All my machines here are back to normal.

I tried the following

yum clean metadata
yum clean packages

Still no luck. Oh well, I wait to see if clears up towards the end of the week. Thanks for the help.


to be honest I do not exactly know which version I was using, I switched on auto-update and tried to trust it to do the job :wink: did that with ordering the stable branch.
If there is a log I can fetch from the server which provides the info this is fine.

About the key, it was present, but there was a new key which changing fingerprint which I had to accept.
Sorry, during the update I haven’t thought much about creating logs and screenshots.