Appliances management port

It is strahge that user cannot change default Appliances management port from 443. And also it would be great to do a http access also. For examle from local network user uses http, and from Internet uses https on port 34764. It is more secure.
Sorry for my english.

Thanks for the request @g2_ufo. I’ve created a github issue to track it.

I was just looking for the option to do this

+1 would make putting Rockstor behind a reverse-proxy possible.

To change Rockstor port:
launch ssh console session
vi /opt/rockstor/etc/nginx/nginx.conf
If you want to change to a port other than 80, simply change “listen 443 default_server;” to “listen ### default_server;” where ### is port you want to listen on.
systemctl restart rockstor
systemctl status rockstor
and ensure Rockstor (and nginx) are started

If you want to change to port 80, comment out the entire port 80 server section:
# server {
# listen 80 default_server;
# server_name “~^(?.+)$”;
# rewrite ^ https://$myhost/$request_uri? permanent;
# }

Then as above.

1 Like

Change nginx is the easy part…

Big problem is: some rockstor systems need api at 443… Try this:

  • ssh
  • change nginx config https port to 1443 (or any other)
  • reboot your rockstor
  • ssh again
  • RESULT: You notice NO pools/shares are mounted… just basic root
  • change nginx config https port back to 443
  • reboot your rockstor
  • ssh again
  • RESULT: all your pools shares are mounted

So my guess is: rockstor startup service need api to perform some tasks

Im now looking how to change “current appliance” settings … my guess if i explain my appliance lives at 1443, rockstor startup scripts will obey and we have peace in system again

Does any one has experience on that?

That’s a shame. I just changed the port in nginx and checked the webui still worked. Didn’t reboot.

The mgmt_port variable appears to be set to 443 by But there are 58 references to 443 in the code, and some of these are hard-coded, rather than use the mgmt_port variable. So the solution is probably to allow mgmt_port to be changed in then replace the hard-coded references elsewhere with mgmt_port.

Thanks for this comment @neyfrota. I see that you’ve already added this useful input to the github issue, which is cool! I’ve bumped up the priority on it. Please stay tuned.

You can now customize the https port as of 3.8-14.02. We have also removed the default http redirect, freeing up port 80 for something else, say apache rock-on etc…

Just want to close the loop on this one. @g2_ufo, what’s the justification for using http over https even locally?

Just wanted to say: great new feature. This allows Rockstor to share an IP address with other web apps that can’t have their port changed from 443, such as out-of-band management. I can now place my backup nas in another location and have complete remote management capability from the BIOS up :slight_smile:

For those who don’t figure it out, this port setting is under System --> Services --> press spanner next to Rockstor --> change HTTPS Port as wished.

No reason to use http IMO.

1 Like