APU2 board and Rockstor 4

I’m trying to install Rockstor on my apu3b4. Its an embedded computer with 4gb ram.
PC Engines apu3d4 product file

Therefor there is no graphic card so I’m trying to install it via the serial console. I’ve added console=ttyS0,115200n8 in the GNUB boot but when it passes the loading of the image, it dosen’t do anyting image

What to do?

Best regards
Soren

@niehans Welcome to the Rockstor community forum.

Yes, the initial grub load is for the installer only. It may be that you will need to have these or similar kernel options baked in. Take a looks at our custom installer instruction here:

You can see form the main config file that for the Pi4 & ARM64EFI profile for instance we have similar kernel options. Add what you think will enable your own console to the x86_64 profile in your own local copy of that repo and do a custom build. You will then have the relevant kernel options built-in and they will be persisted in the resulting installed image.

I’m not convinced this is the issue here but jotting down just in case.

Hope that helps and let us know how it goes. Incidentally, when building your own installer, all of the latest package from upstream are used. So it may well be that an update there-in might help also.

1 Like

Hi Phill

Thanks for the great answer.
I managed to install it after a lot of trial and error. At the end I tried booting from the hdd and with the kernel set to serial console it ran through the installation.

:wink:
Cheers
Soren

4 Likes

@niehans Well done, and thanks for the update.

Do you fancy details just how it was done. I.e. the exact kernel options that worked for your, and any other specifics, i.e. was it absolutely required to have the installer work from the hdd, or have I mis-understood there. Always good to collect such info here as it can lead to custom profiles in our installer for example, so that others can be up-and-running all the quicker. Exciting to see Rockstor on this devices.

Do all the ports work as intended? I.e. I see a regular sata connection there, but there is also an mSATA / mPCIE are they all recognised and working. And the 3 Gigabit ethernet (nice), do they all work. Always good to have feedback on the more unusual devices.

Thanks again for you feedback and glad you are now up-and-running.

2 Likes