At boot: exception Emask (HSM violation) [3.8-12]

My system doesn’t boot up anymore but it was running just fine on tuesday.
I’m using stable channel and I think that auto-updates are enabled.

Since I’m using an ASRock c2550D4I with 12 S-ATA ports I can only assume that ata18 refers to the system sdd connected via PCI-E.

M-ware ID13603 bootable PCIe x1 mSATA controller

I tried normal and recovery boot.
Any suggestions?

Kind regards

@OpenSourceUser Was this after a kernel update, ie can you try booting from a previous kernel version to see if it’s a compatibility issue with a newer (and default) kernel.
From a quick look at libata_error_messages it would appear to suggest a hardware issue. So re-seating all connectors and testing hardware using live boot systems to try and diagnose further ie running smart tests using live linux distro’s or just seeing if all the drives show up, and looking at the dmesg of those live boots.

1 Like

After several reboots (and I mean a lot of reboots) the system was running again… but only once. So I rebooted the system again and again until I was able to install the latest testing update (3-8-12.04). Seems like the problem is gone with kernel 4.4.5-1
I’ll keep you updated :wink:


Do you know any specifics about what fixed it in 4.4.5?

I don’t have any clue to be honest. Found some older Ubuntu-related topic somewhere on the internet dealing with a similar issue which could be fixed by updating the kernel. That’s why I tried that.

Now - more than 20 days later - I can confirm that the error did not occur ever again :ok_hand: