Bad tree block start error after installation

Tried installing multiple times on USB and hard drive but I still get the follow errors once I login to rockstor gui.

“BTRFS error (device sdg3): bad tree block start”
“BTRFS error (device sdg3): qgroup scan failed with -5”

Any idea what these errors mean?


@Cujo360 Welcome to the Rockstor community.

This errors could result from general corruption, or from a ‘bad’ install. I’d first try checking the machines memory via memtest86 (it’s build into the installer as a boot option), or making sure you are installing with default options (ie no custom partitioning for example). Rockstor includes the upstream CentOS installer but is not able to work with all of it’s possible install options so always best to go with the defaults, at least at first. We are to move to a more restrictive install method as we move to openSUSE, but will also accommodate an ‘advanced’ option of installing into generic openSUSE. But that is a little way down the line currently.

Hope that helps and it may be that others will chip in with other possible ideas on this rather unusual failure.