Bootload install failed

Hello I’m having trouble with installing Rockstor on my xeon haswell machine. The installation goes fine till the boat loader point then doesn’t go any further. I have tried auto partitioning and manual and still no success. any help would be much appreciated.

Hi @Nxdibbles,

Could you provide a little more information?

  • Are you stuck in the installer, or has the install finished and failing to boot?
  • Does the system still respond to input?
    • If in graphical mode, can you still move the mouse?
    • Otherwise, are keypresses displayed on screen?
  • What is displayed on the screen?
  • When you started the installer (on the install disc’s boot loader) do you see the rockstor logo, or no logo at all?
  • Is UEFI boot enabled or disabled on your machine?

-installer doesn’t finish saying “boot loader failed to install do you want continue” and if continue and finish it doesn’t boot.
-respond to input yes both keyboard and mouse.
-The message in “” above.
-logo and menu e.g. install, troubleshoot etc.
-UEFI boot is enabled and legacy.

Thank you for quick support

Hi @Nxdibbles,

That’s interesting. We’re still going to need some more info for the time being. How familiar with Linux are you in general?
Specifically, we need some log information.

When you’re at the screen stating “Boot loader failed to install”, we’ll need to switch to a text console to find out what went wrong.

You can switch to a text console using Ctrl + Alt + F2.

When in the console window, we are after the anaconda logs which (last time I checked) are in /tmp:
If you can transfer these to a USB disk, upload to pastebin or a similar service and link them, we’ll see if we can figure out what’s going wrong.

yes will do it in the morning

Sorted the ssd I was installing on was GPT converted back to mbr and installed and running


Glad to hear it’s also sorted.

There have been GPT/UEFI issues reported in the past, however that typically leads to a completed installation followed by dracut/initqueue timeouts and dracut shell.

For posterity, just in case the devs identify something that needs fixing, would you mind posting your Anaconda install logs from the failure (if you still have them)?

what about harddrives with over 3tb. does rockstor support gpt for those

ok - i have an old set of btrfs disks - server got dropped and mobo went south

transplanted new mobo and downloaded latest 3.9.1 rockstor

install failed with dracut initqueue timeout (another issue)
fixed the dracut issue by typing “e” on the install centos 7 option and replacing the


with (after dropping into emergency mode - which it will do for you - “ls /dev/disk/by-label”
you will see the USB stick there)

mine was hd:LABEL=Rockstor\x203\x20x86_64

this will at least get install to commence

i zeroed out the .M2 drive and reformatted to GPT but rockstor says it can’t write the boot block - so just attempting to reformat to MBR and hope this works

will update on progress