BTRFS repair - mount wrong fs type


my RAID 5 with 4 disks has one disk failure. I thought, okay, no problem, change it and it will be ok. I’ve done it once, so it should be no problem, but i’ve proven me wrong.

The bad disk is sdb(devid 4)
And when i try to mount the FS in degraded mode, it says wrong fs type.
device /dev/sda: failed to read chunk tree -5
device /dev/sda: open_ctree failed


[root@nas ~]# btrfs fi show
Label: 'rockstor_rockstor'  uuid: d323aac9-d70a-4022-a631-49f3082380bb
    Total devices 1 FS bytes used 3.80GiB
    devid    1 size 49.82GiB used 34.30GiB path /dev/sde3

warning, device 4 is missing
bytenr mismatch, want=12944226566144, have=12944226762752
Couldn't read chunk tree
Label: 'store'  uuid: 7a358cf9-41f2-466c-9629-57b15daf8337
    Total devices 4 FS bytes used 7.36TiB
    devid    3 size 3.64TiB used 2.69TiB path /dev/sda
    devid    5 size 3.64TiB used 2.69TiB path /dev/sdc
    devid    6 size 3.64TiB used 2.69TiB path /dev/sdd
    *** Some devices missing

[root@nas ~]# mount -o degraded /dev/sda /mnt2/store
mount: wrong fs type, bad option, bad superblock on /dev/sda,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

[ 1230.494748] BTRFS info (device sda): allowing degraded mounts
[ 1230.494752] BTRFS info (device sda): disk space caching is enabled
[ 1230.494753] BTRFS info (device sda): has skinny extents
[ 1230.638994] BTRFS info (device sda): bdev (null) errs: wr 1767, rd 695, flush 514, corrupt 0, gen 0
[ 1230.638998] BTRFS info (device sda): bdev /dev/sda errs: wr 0, rd 251, flush 0, corrupt 0, gen 0
[ 1231.359262] BTRFS error (device sda): bad tree block start 0 21167414001664
[ 1231.360643] BTRFS error (device sda): failed to read block groups: -5
[ 1231.395040] BTRFS error (device sda): open_ctree failed

Nothing helped so far. I’ve tried chunk recover, zero-log.
And I already searched all similar threads, but nowhere I found a solution.

Is there any chance, to recover the raid?

@markus Welcome to the Rockstor community.

Which version of Rockstor are you using to attempt this poorly pool mount? I would strongly suggest that you try our non legacy Rockstor 4 which is at Release Candidate 7 stage (once updated to the latest available within the testing channel):

There is as yet no installer download available but you can make your own with all updates auto pre-applied via the instructions available in the following GitHub repo:

Best if you use a seperate system disk for this install and don’t have the original Rockstor 3 system disk attached. It confuses the new install. That way if you do get the pool back you can always revert to the prior system disk and pick-up where you left off. Although a re-config of the Rockstor 4 to your requriements would be better but that is not the question here.

That way at least you get a far more modern btrfs subsystem than you might otherwise be using if you are still using our now legacy CentOS variant of Rockstor 3.

The huge number of fixes in the stack between these versions may well increase your changes of establishing a successful mount. Your pool may also be sufficiently poorly to require not only a degraded option but also a ‘ro’ read only option. This would at least enable you to refresh your back-ups.

From your log it does look like sda also has errors:

A good practice in this situation is to double check your memory health also. as both the removed device bdev (null) had errors of read and write as well as the still remaining sda. And raid5 can only handle a single drive failure, where as these stats tend to indicate 2 drives have gone fault. Hence the memory check just in case. See our: Pre-Install Best Practice (PBP):
specifically the Memory Test (memtest86+) section:
and double check, re-connect all cables.

Hope that helps.


Hi Phill,

thanks for the answer.

I’ve installed Rockstor 4 on another Disk and tried, but no luck so far. Same errors :frowning:

The RAM is totally fine. Checked it with memtest.

I make now a copy of the other disk, wich is showing also failure, so i don’t kill the original disk.
SMART says the disk is also totally fine. And Rockstor itself had also no complaints about it a few hours before the other disk freaks out.

Any suggestions how to use BTRFS check right?

Okay, i give up.
Tomorrow i will call a datarecovery company. That is my last hope.

And after that i will switch back to ZFS. Much more stable and robust.