Built on SUSE Update to 4.0.3-0

Got some unexpected update behaviour on my RockPi. That’s a Pi4 of course.

Got the flashing indicator next to ‘Built on SUSE…’ rather than the up arrow next to the Rockstor version above.
Started update from flashing icon. It appeared to complete, but a screen refresh brought the flashing icon back, and the original 4.0.2-0 version.
SSH tells me that package Rockstor is available to update. Went back to GUI to try again. Same thing, and SSH telling me Rockstor is available to update, so went the zypper route in SSH.
That did the trick.
Will test it out.


PS Apparently I’m a month late to the party :wink:


@GeoffA Thanks for the report.

Yes, I’ve now edited the release post re Sep instead of Oct.

Not sure quite what happened re the failed updated. Nothing has changed re the updated procedure in code so bit of a mystery. However my initial guess would be that as we inform of the update via yum (actually dnf yum plugin) but do the update via zypper. There’s a very good chance that one had updated it’s cache/knowledge of repo, while the other had not yet done that. And when you did via command line it did update. We may be missing a trick here somewhere but we do run zypper refresh so don’t know why that didn’t do the job. Possibly due to having recently done it in the background and so it wasn’t due to do it again for another hour or so.

Incidentally we use dnf-yum as it can given changelog info of non installed version, where as zypper does not yet have that capability. That way we can show the pending changes from the latest repo rpm. It’s also historical as there’s a bunch of stuff already coded to parse the output form yum/dnf-yum that we wanted to preserve.

It may well have been that if you had tried again in a little whiles time it would have worked. If you encounter this again give that a go and report on your findings. I’ll see if I can reproduce here. Nice find however and this has not been reported previously. But I now see how it could happen. Hopefully it’s not that critical and will only exist in a short time frame post each repo update… I published the rpms about a minute or two before publishing the forum post. Both x86_64 and Arm64 rpm repos were updated in parallel. We use to have our repos polled every minute but that ends up adding up on the server load so switched to hourly polling/metadata timeout on the yum side. On the zypper side we go with defaults.

Once we have the stable release out we hope to get on with that Rock-on arch thing, so that does put the Arm64 a little behind but that’s about all that differs from what I can tell.

Again thanks for the super fast feedback and for testing on the Pi4. Nice.

1 Like

@phillxnet yes I was quick off the ball to initiate the update. Maybe a slight delay would have been more appropriate :slight_smile:

Anyway, RockPi is still rock stable. I’ve now pointed my media servers (Logitech Media Server and Jellyfin) to RockPi for the weekend to test - the weekend is time for heavy usage in our house.




So I’ve been running 4.0.3-0 on my RockPi since Friday without any issues. I’ve managed to partially overcome my previous inability to get the Pi to boot from USB when other USB drives are also attached: it appears to work fine with a USB stick, but not my USB SSDs using USB/SATA adaptors which work fine with Debian. I will revisit this at some point, but I’m pleased to have a stable and easily rebootable RockPi.

I think we’ve tested it pretty well over the weekend. I’ve managed to refrain from logging in to the GUI, and have just let the family use it as intended, streaming music and videos, photos, storing documents & homework etc. And it does all that without fuss or bother.

I’m not a big user of Rockons but I did install Plex just to see how that went, and it went without a hitch.

And just to add to this, my AMD64 box running Stable 3.9 Rockstor suffered a hardware failure (mobo, not storage) and so is out of action. To be honest, I’d be happy to move to the Pi going forward - perhaps this is the push I needed.

Anyway, the point of this post is really to say well done to the team for getting this pretty much ready for showtime. I’m looking forward to the move to Stable for Rockstor 4, and if possible will probably move my Stable subscription from the dead AMD64 box to my fully-functioning Pi4. Is that possible or allowed?

Thank you.




@GeoffA Thanks for another report. Very encouraging.

I’m still at a loss on this one myself, and I’ve yet to experiment more in this area. But as more folks get an install on their Pi4 we should hopefully be able to resource their knowledge and get this sorted, or worked around. Have you tried changing which USB ports are used for example?

Good to know the Plex install was find for you on the Pi4. We do have work to do on surfacing Arm64 compatibility per rock-on but all in good time.

Possible, encouraged, and doable via Appman with immediate effect:


That’s essentially what Appman is for in fact. Just sign-up/in using your order email and it’s then fairly self explanatory. The first page after login explains it’s primary purpose and that fits your current circumstance nicely.

The Stable repo for the ‘Built on openSUSE’ endeavour is currently empty, but you should still be able to subscribe just fine. Although we have had some reports that it can generate an error. But see how you go. And it’s looking like the 4.0.3-0 is likely to be what we promote to Stable anyway. Plus we have some large changes that can’t wait much longer so I’m eager to get them into testing so we can start our journey towards the next stable channel release in the current testing channel.

If you get any problems with Appman or the stable registration just Private Message (PM) me here in the forum or email support and I’ll take a look. But you should be just fine.

Shame about the AMD64 box. But at least it’s not the hard drives / storage.

Thanks for reporting your findings and do let us know how things progress. Much appreciated. And thanks again for helping to kick off the Pi4 testing. I’m hoping we get more Pi aficionados testing and reporting as I’m very new the Pi land myself as it goes.

Hope that helps.

1 Like