Can no longer connect to my network?

Very much a newbie here… I tend to fumble into success without much knowledge. I got Rockstor up and running on a dell power edge T430 server, installed Plex Rock-On and have been loving it for a couple of months. Then it went sideways. I replaced my internet provider and Router this weekend and now my server does not appear on the device list of my router and I have no access to the Web-Ui.

Any thoughts?

Welcome @msperos to the community forums
Could it be that with your previous router/internet provide you assigned a static IP address to Rockstor that is not part of the new router’s setup (e.g. assigned 172.16.0.199 in the past, and your new router follows the 192.168.0.xxx mask)? At the end of bootup the Rockstor system will show its host IP address.

I assume, you can also not connect remotely to the server (anymore) to just run
the hostname -I command to get the IP address it is registering under?

1 Like

My rockstor IP is 192.168.0.73. The new router was running 192.168.1.1. I went into the router and switched it to the .0.1. Still nothing. Rockstor boots. shows Https:192.168.0.73 . But my router does not show it on the network. I have switched cables and even drug the server up yo the router and plugged straight in, nothing. going into the linux utility I show the ethernet card still showing the rockstor address 192.168.0.73 and the gateway as 192.168.0.1. Should I mess with the DNS servers listed on the IPv4 Config on the server. Or is there a way to tell my router to allow the DNS listed on the server to work?

Since it seems you have a monitor connected to the server, you can log into the system and using the NetworkManager (underlying framework to manage network connections used by Rockstor and determine the active interface(s) you have by typing:

nmcli device status

Identify the interface that has a connection. Use that connection name to review the profile via:

nmcli -p con show <ConnectionName>

this should give you a screen output with multipe sections. If it’s anything like mine, there will be a list of connection properties, followed by list of properties of the connection type (e.g. 802-3-ethernet), which is then followed by ip4 and ip6 properties. the ip4.method property would show “auto” if it was set to receive its IP address and other settings (e.g. Gateway address) automatically. If it doesn’t, then probably a command line editing is needed (using the nmcli editor). There is a wiki entry for the Networking architecture that you can take a look at:

But I also hope, that somebody else can chime in, especially if there are more effective ways exist to analyze and remedy this.

1 Like

I believe that I have been in the editor Function and the DNS is still listed as my old century link DNS address
It shows Gateway witch is my current IP for the router
a DNS that is the Same IP address as the router
and two other DNS address that are my old Centurylink router DNS

So if I identify my current DNS listed in my router setup IE: Xfinity DNS. I could go into the nmcli editor and change those entries to match.

Does that sound right.

Based on your response it sound to me that the connection (and associated parameters) was statically defined, correct?
If so, this might be your best option to get back into the WebUI (and then review the settings there, and possibly make adjustments to have the process re-aligned with how Rockstor manages the connections).

Well, Between cold medicine and scotch, still not working. Getting lost in the linux editor functions. I have been messing in nmtui not “nmcli c edit” kinda getting lost.

If any one could point me to the format to tell it my network info that would be great. I think I will go have a shot of Nyquil and Laphroig and battle this beast again tomorrow.

Cheers from Colorado
Mark

Good luck on the cold medicine/scotch remedy. If it’s of any help, here’s a working interface displayed using nmtui

image

The device name is followed by the actual MAC address (not the placeholder I put there).

As you can see, pretty much everything is set to automatic. I set a static IP in the router as opposed to on the device itself …

1 Like

well now my ethernet adaptor/connection em1 is showing unavailable…and I can not activate it in the nmtui screen.

@msperos, have you made any more progress on this? Did you mess more with the connection configuration?

Is your network card still recognized by the system, using e.g.
lspci
I assume, one or more ethernet controllers should show up. If none are, then maybe there is a hardware issue …